Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We’re making changes to the Unity Runtime Fee pricing policy that we announced on September 12th. Access our latest thread for more information!
    Dismiss Notice
  3. Dismiss Notice

Post Processing not applied to camera

Discussion in 'Image Effects' started by PhilippCh, Sep 3, 2019.

  1. PhilippCh

    PhilippCh

    Joined:
    Jun 14, 2013
    Posts:
    19
    Hi there,

    I seem to have a constant issue with applying PostProcessing to my camera. Using the current 2019.3.0b1 with the LWRP I've done the following things:

    - Set up PostProcessLayer/Volume correctly (see attached screenshots)
    - Checked Render PostProcessing on camera (via UniversalAdditionalCameraProperties)
    - Set up some effects to see anything at all
    - Debugged into UniversalRenderPipeline and ForwardRenderer to see the post process pass actually being enabled and added (which it is).
    Anmerkung 2019-09-03 193651.png ´
    Anmerkung 2019-09-03 193607.png

    I observe that when I change the anti-aliasing mode via the additional camera properties, it is applied, but the Anti-Aliasing set through the PostProcessLayer never takes effect.

    Do you have any ideas what could be causing this?

    Best Regards
    Philipp
     
  2. StaggartCreations

    StaggartCreations

    Joined:
    Feb 18, 2015
    Posts:
    2,102
    The PostProcessLayer component is part of the Post Processing Stack v2, which is no longer compatible with the scriptable render pipeline since 2019.3. Basically, you can delete the entire package from the project :p

    You'll only need a Volume set up as you have already, and the "Render Post-processing" checkbox ticked on the camera.
     
  3. PhilippCh

    PhilippCh

    Joined:
    Jun 14, 2013
    Posts:
    19
    Thanks a lot, I can't remove the PostProcess package though since apparently LWRP still depends on it.

    Do you also have an idea where I can find fog settings? All I'm currently seeing in the volume overrides are post processing effects. The fog checkbox in the lighting inspector is greyed out.
     
  4. StaggartCreations

    StaggartCreations

    Joined:
    Feb 18, 2015
    Posts:
    2,102
    Since 2019.3 the Lightweight RP just acts as an installer for the Universal RP package, these are currently the same pipeline, just renamed. So you can remove the Lightweight RP package along with the Post Processing package at this point.

    As far as I know the URP only has post processing volume components, whereas the HDRP has sky, lighting and fog components. I don't know what causes the fog settings to disable for you, I'm using the same Unity version (but with URP) and can use the default fog settings.
     
    GoGoGadget and timbokoppers like this.
  5. sebas77

    sebas77

    Joined:
    Nov 4, 2011
    Posts:
    1,590
    I can't find the equivalent of the PostProcessLayer, PostProcessProfiler and PostProcessVolume classes and I am baffled by the lack of references in the documentation. It's like it was supposed to work or we are supposed to know what we should do?
     
    bettywhite likes this.
  6. sdb7

    sdb7

    Joined:
    Apr 8, 2013
    Posts:
    23
    This is for anybody stumble to this post looking why their post processing doesn't work on URP even after downloading the Post Processing Package :

    On URP now post processing doesn't need to be installed and just put Volume component and tick Render Post Processing On camera component
     
    bigibby and chzwhz like this.
  7. atulvi

    atulvi

    Joined:
    Oct 28, 2020
    Posts:
    35
    URP Post-processing
    ——————————-
    1) Install URP package via package manager.
    [Post processing via package manager does not install. It’s not necessary. URP does not support PPv2]

    2) Create Global Volume in hierarchy.
    [ex. create 3dobject > cube]
    —> Right click > volume > global volume
    —> click on new button[create volume profile]
    —> Add override > post processing > add any effect.
    [Must set in your URP rendering pipeline > Post processing > Featured Set : Integrated ]

    3) How can enable post processing.
    —-> MainCamera > Rendering > post processing Tick in check box.

    [it’s not necessary to add post processing layer component to camera or VR camera.
    please remove the post processing layer in camera.it’s not supported in URP]

    Useful Link: https://docs.unity3d.com/Packages/c.../manual/integration-with-post-processing.html
     
  8. Rapidoso

    Rapidoso

    Joined:
    Jan 2, 2021
    Posts:
    1
    I am in the 2020.3 in the Pipeline Preset and my cameras don't have the Post Processing Checkbox (is enabled the Universal RP in the Package Manager)
     

    Attached Files:

    • LoL.png
      LoL.png
      File size:
      427.7 KB
      Views:
      467
    RosMedia and bettywhite like this.
  9. atulvi

    atulvi

    Joined:
    Oct 28, 2020
    Posts:
    35
    Please install stable release for URP package from package manager.
    Also check the URP render pipeline asset passed in Graphics Settings.

    ==> Please try without pipline preset.