Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. We are looking for feedback on the experimental Unity Safe Mode which is aiming to help you resolve compilation errors faster during project startup.
    Dismiss Notice
  3. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Post-Processing effect not visible when using LWRP

Discussion in 'Graphics Experimental Previews' started by alpha_rat, Jan 4, 2019.

  1. alpha_rat

    alpha_rat

    Joined:
    Apr 18, 2015
    Posts:
    6
    We are running into an issue when setting up Post-Processing effects for the new Lightweight render pipeline.

    Post-processing effects are visible in scene and Game view, but not through the camera when running the game.

    - The project is using single pass rendering for VR
    - We are using the LWRP 3.0.0 and the Post-Processing package 2.1.2 (both are up to date)
    - It seems like the Post processing volume and layer settings are working fine, as the effects are visible in scene and game view

    We tried :
    - tweaking the quality and graphics settings
    - creating a new camera and setting the post processing settings again
    - removing all additional cameras in the scene
    - setting the exiting UI Canvas in the scene to Screen Space (Camera) instead of Screen Space (Overlay)

    Any additonal tips and hints about what we should try?
    Thanks ;)
     
  2. phil_lira

    phil_lira

    Unity Technologies

    Joined:
    Dec 17, 2014
    Posts:
    546
    Post-Processing and VR is not working in 3.0.0 version.

    It's working in 19.1 by using 5.2.0 version and above.
    In 18.3 it will be supported soon in 4.7.0-preview.
     
    alpha_rat likes this.
  3. sidwasnothere

    sidwasnothere

    Joined:
    May 3, 2018
    Posts:
    6
    Post Processing Layer works (well, the FXAA works and only in fast mode), but the actual Post Process Volume does not work at all. This is on LWRP 5.7.2, Post Processing 2.1.7 in VR, Unity 2019.1.2f1.

    Maybe I'm doing something wrong but I've looked at every forum post and youtube video I could find but nothing has worked so far.

    Edit: I am a fool nevermind it totally works
     
    Last edited: Jun 14, 2019
  4. MyCheeseNacho

    MyCheeseNacho

    Joined:
    Apr 3, 2019
    Posts:
    1
    How did you make it work? I can only do Antialiasing but not anything else. Im in 2019.1 with postporcessing v2. Is there something im missing?
     
  5. Leslie-Young

    Leslie-Young

    Joined:
    Dec 24, 2008
    Posts:
    1,053
    In case someone find this thread with no answer. I was stumped for a while cause I placed my PostProcessVolume component on the main camera, seeing as it is Global, but you need to set the layer too.

    So, best is to make a new object with the PostProcessVolume on it and assign the correct Layer, for example the "PostProcessing" (layer 8). Basically whatever you chose for the "layer" property of the PostProcessLayer component.
     
  6. idavida

    idavida

    Joined:
    Nov 12, 2012
    Posts:
    29
    Yeah this is not working on an updated project. Whatever I try and the only way to get my effects to work is to remove UWRP from settings in quality in project settings.

    I have a clean scene with two objects, a camera with a post process layer on it, set to a postprocess layer, and another gameobject with a volume and vignette. And nothing.

    Is this bugging for some users or or am I missing something here...?

    I must say I'm kind of well versed in the Unity-universe, but holy crap the rendering pipelines are killing me with bugs and unsupported features.
     
unityunity