Search Unity

Post Processing Effect from External Package Does Not Export With Build

Discussion in 'Editor & General Support' started by spillodo, Jun 17, 2022.

  1. spillodo

    spillodo

    Joined:
    Aug 22, 2020
    Posts:
    1
    Hi, my Unity Project (version 2020.3.27f) has a post processing effect on its camera which displays properly in the editor's game view, but not in the build. I have double checked to make sure there is only one camera in each scene, and some of the post processing effects (a colour correction layer) work in the build. It is only the effect from the package (RogueNoodles GBCamera for Unity). I'm not sure how I can fix this -- I should mention I am fairly new to Unity. Thanks in advance for your help!
     
  2. NicolasK98

    NicolasK98

    Joined:
    Feb 9, 2017
    Posts:
    1
    I have the same problem. It seems that RogueNoodles GBCamera for Unity have a problem on build with the new Post Processing v2.
    Have you found a solution?
     
  3. Saveforth

    Saveforth

    Joined:
    Jan 28, 2022
    Posts:
    3
    I have the same issue with the same package, did you guys find a solution? I originally thought it would be because the shaders weren't added in the project settings > graphics > always include shaders, which had been the solution to a similar problem in the past, but not this time it seems.

    Edit: That was the solution, I was just missing the shader at RogueNoodle > GBCamera > Post Processing > Shaders
     
    Last edited: Oct 8, 2023
  4. Saveforth

    Saveforth

    Joined:
    Jan 28, 2022
    Posts:
    3
    I had the same issue, which was similar to another issue I had a year ago, and luckily they had the same solution. You just have to add the shaders to the "always use" section because unity doesn't add shaders that don't have references in a scene (it's confusing, I barely understand) but you do "edit > project settings > graphics > always include shaders" and then just increase the size and drop in the shaders. I increased it by 3 and dropped in the two shaders at "RogueNoodle > GBCamera > Shaders" and also the one at "RogueNoodle > GBCamera > PostProcessing > Shaders" I don't know if all 3 are necessary, I'd bet that you only need the post processing one, but I added all 3 just in case.