Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  2. Ever participated in one our Game Jams? Want pointers on your project? Our Evangelists will be available on Friday to give feedback. Come share your games with us!
    Dismiss Notice

Bug Possible Bug: Involving Unity Assets/Downloaded Package contents when hiding that folder

Discussion in '2020.1 Beta' started by omzGaming, Apr 6, 2020.

  1. omzGaming

    omzGaming

    Joined:
    Jan 23, 2020
    Posts:
    55
    I just ran across something interesting and totally by accident.
    I just watched my​

    How to Recreate:
    1. Download Polybrush from Package Manager
    2. Under Assets in your project folder, Right-Click the Polybrush folder and select "Show in Explorer"
    3. When the Explorer window opens, Right-Click Polybrush and select Properties.
    4. After selecting Properties, check the box marked "Hidden" near the bottom
    5. Go back into Unity and Tools/Polybuilder/Polybrush Window

    If you do this correctly, the Polybrush window attempts to load the default settings that are located inside of that folder. Upon hiding this folder in the Explore, Polybrush is unable to locate the default settings and attempts to recreate it's default settings.

    However, once the folder is hidden in the Explorer, it just duplicates the original settings over and over. If you don't close this window, it will never stop duplicating the settings.

    You can then look at all of the duplicates inside of your Polybrush folder...
    • Go back into the Explorer by right clicking the Assets Folder and Click Show in Explorer.
    • Show your hidden files on your computer and then open up the Polybrush folder.
    • I had around 275 copies of the default settings that had been duplicated in seconds
     
    Last edited: Apr 6, 2020
unityunity