Search Unity

Audio Poor Audio Quality - Editor vs Phone

Discussion in 'Audio & Video' started by cteixeira, Mar 14, 2019 at 8:21 PM.

  1. cteixeira

    cteixeira

    Joined:
    Sep 25, 2018
    Posts:
    1
    Hi everyone,

    I'm fairly new to Unity but I have been having an interesting problem with sound quality. No matter the settings the sound effects sound fine and normal in the editor, but when I build the game to Android or iOS it seems like there is a lowering of sample rate, or bit rate which causes the audio to sound different.

    Here's a sound clip of an underwater level, where an animation happens that drops coins over your screen. In the editor it sounds normal, and on any phone i've tried it sounds garbled.

    *note that the same recording chain was used to record both instances*

    (editor vs build - same sfx) https://drive.google.com/file/d/11WZpM89Yh15O3dBeU0PhnYMFqgyX3xy6/view?usp=sharing

    (coin sound effect) https://drive.google.com/file/d/1pDP4XAAHf5-U9kaMPqMOyzX-W0l7EUxI/view?usp=sharing

    The settings i've tried include;
    1) Mono/Stereo 16 bit 44.1 khz WAV (sounds garbled, loss of high frequencies)
    2) Mono/Stereo 16 bit 44.1khz Ogg Vorbis (sounds garbled, loss of high frequencies)
    3) Mono/Stereo 16 bit 48khz WAV (sounds garbled, but no loss of HF)
    4) Mono/Stereo 16 bit 48khz Vorbis (sounds garbled but no loss of HF)

    If anyone has any experience with this or can lead me in the right direction that would be amazing.

    Thanks,
    Chris