Search Unity

Terrain Polybrush shader renders invisible on Oculus Quest

Discussion in 'World Building' started by Grimlock_Arts, Nov 12, 2019.

  1. Grimlock_Arts

    Grimlock_Arts

    Joined:
    Oct 18, 2019
    Posts:
    12
    Is anyone else having problems getting Polybrush objects to render on the Quest? I'm using Polybrush version 1.0.1 on Unity 2019.2.10f1. The mesh is just not rendering but the collider is there and I can move on it. I don't know if it's one of my settings or if it's just the Polybrush shader. If I slap a texture with no shader or a standard unity shader on the mesh it renders but not with the Polybrush shader. A setting I'm missing maybe?

    EDIT: Standard rendering pipeline

    Is the provided Polybrush shader not compatible with android devices? I see it (polybrush shader object) in Unity when I press the "play" button. The Quest is Android based. If so, would it be possible to build a custom shader to get this working?

    REQUEST: Can one of my fellow Unity users who's working with Oculus Quest create an empty scene, a probuilder plane, and attach a Polybrush shader to it and see if it renders in the headset? I'm curious if Polybrush is just not an option for any of us currently. I was hoping to get my project released by Xmas but it may not happen now if Polybrush is broken/not compatible.
     
    Last edited: Nov 12, 2019
    Lukey_BlueNose likes this.
  2. donb98

    donb98

    Joined:
    Dec 7, 2019
    Posts:
    2
    same here, i'm not using probuilder but my own custom meshes :/
     
  3. vanhalen17

    vanhalen17

    Joined:
    Apr 19, 2015
    Posts:
    61
    Having this as well, any fix?
     
unityunity