Search Unity

  1. Dismiss Notice
  2. Looking for a job or to hire someone for a project? Check out the re-opened job forums.
    Dismiss Notice
  3. Unity wants to learn about your experiences working on a Unity project today. We'd like to hear from you via this survey.
    Dismiss Notice
  4. Unity 2020 LTS & Unity 2021.1 have been released.
    Dismiss Notice
  5. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  6. Read here for Unity's latest plans on OpenXR.
    Dismiss Notice

Player Settings: Virtual Reality supported

Discussion in 'EditorXR' started by MPW2019, Apr 20, 2019.

  1. MPW2019

    MPW2019

    Joined:
    Apr 20, 2019
    Posts:
    1
    Where can i check these? under player settings i cant find these issue.
    Thanks a lot
    Tina
     
  2. amirebrahimi_unity

    amirebrahimi_unity

    Unity Technologies

    Joined:
    Aug 12, 2015
    Posts:
    376
    It's under "XR Settings" at the bottom in Player Settings.
     
  3. RGarren

    RGarren

    Joined:
    Oct 1, 2018
    Posts:
    2
    im in 2020 and used to see the setting for XR, but i just reinstalled unity and now i dont see it
     
  4. amirebrahimi_unity

    amirebrahimi_unity

    Unity Technologies

    Joined:
    Aug 12, 2015
    Posts:
    376
    Yes, those settings were removed in Player Settings in Unity 2020 and are now located under "XR Plugin Management" in the Project Settings window.

    Unfortunately, though, the new XR plugin management system isn't currently supported by EditorXR, so you'll need to stick with 2018.4 - 2019.3 for now.
     
    VincentV_Philips and RGarren like this.
  5. nous

    nous

    Joined:
    Mar 23, 2014
    Posts:
    3
    How can I change the Stereo Rendering Method? I modified it, did an upgrade, and need to move it back.
     
  6. amirebrahimi_unity

    amirebrahimi_unity

    Unity Technologies

    Joined:
    Aug 12, 2015
    Posts:
    376
    I'm not sure exactly. If you are using source control, you could try to revert the .asset file under ProjectSettings that got modified. That's probably something you'll need to ask in the general VR forum: https://forum.unity.com/forums/vr.160/
     
  7. RGarren

    RGarren

    Joined:
    Oct 1, 2018
    Posts:
    2

    Thats what ive been doing. Thanks for the reply
     
  8. JyoKad

    JyoKad

    Joined:
    Sep 28, 2020
    Posts:
    1
    noooo... what a pain!!!
     
  9. oliVRqin

    oliVRqin

    Joined:
    Apr 28, 2020
    Posts:
    4
    Was just agonizing over a similar problem, and I'm using Unity 2020.1.9f1 on a Mac; this solution might not work for you cause of different circumstances but it worked for me. My solution was to go to Edit -> Project Settings -> Player -> Under Other Settings, change the minimum API from whatever the default is to 'Marshmallow' Level 23. That's it, worked like a dream. Good luck!
     
  10. smartytizzy1

    smartytizzy1

    Joined:
    Nov 10, 2020
    Posts:
    1
    I'm using unity 2020.1.10f1 on window but i cant find virtual reality supported
    am stuck please help
     
  11. amirebrahimi_unity

    amirebrahimi_unity

    Unity Technologies

    Joined:
    Aug 12, 2015
    Posts:
    376
  12. MB_FRAG

    MB_FRAG

    Joined:
    Sep 23, 2020
    Posts:
    1
    Is this all that you did? I’m am currently facing the same issue on my iMac as well .
     
  13. SirHanselot

    SirHanselot

    Joined:
    Feb 19, 2017
    Posts:
    4
    Hello!

    Is there any way to disable VR for Android Builds in Unity 2020.3.4f1? I want to deploy my project to both Quest and phone (without VR). On my phone it always wants to start GearVR after deployment, although i have disabled "Initialize XR on StartUp".
     
  14. SirHanselot

    SirHanselot

    Joined:
    Feb 19, 2017
    Posts:
    4
    Hi again!

    If found a way to solve this problem.
    1.) You have to uncheck Oculus in your Android XR Plug-in Management to prevent Unity from writing the VR-Tags to your AndroidManifest.xml

    upload_2021-4-16_8-13-27.png

    2.) The current issue is that the OVRGradleGeneration.cs overrides the automatically generated AndroidManifest.xml and enables VR again, even if its deactivated in Unity. So I just add a simple return statement in the according function, if I want to deploy to "flat" Android:

    upload_2021-4-16_8-16-38.png

    And it works!!

    One note:
    I also tried to supply a custom AndroidManifest.xml in the Assets/Plugins/Android folder, without VR settings, but the Oculus OVRGradleGeneration script runs afterwards, so the VR tags are added again.

    In my current situation this is the least invasive action.... to keep everything else untouched. Hope this helps someone. And if you have a better solution, let me know!

    Cheers
     
unityunity