Search Unity

Player not running on primary display

Discussion in 'General Graphics' started by RElam, May 2, 2016.

  1. RElam

    RElam

    Joined:
    Nov 16, 2009
    Posts:
    375
    So trying to get my app setup to not use the startup resolution dialog, but for some reason if I disable it the game will startup on the wrong monitor, and I'm not seeing any way to fix that. With the resolution dialog active, launching the game will default to display 3 in the (which is my primary display), but with it disabled, it starts on display 2.

    Does anyone know how I can find the primary display or otherwise how to fix this (seems like a bug to me)?

    Running win7, 5 monitors, and 5.2.1p4
     
  2. RElam

    RElam

    Joined:
    Nov 16, 2009
    Posts:
    375
    bump
     
  3. iivo_k

    iivo_k

    Joined:
    Jan 28, 2013
    Posts:
    312
    Similar problem with Win 10, 2 displays, 5.3.5p1. Build without startup dialog starts on my 2nd display, which is display nr 1 but not the one set as main display.
     
unityunity