Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Question PlayableAsset from AssetBundle is null on Oculus Quest 1

Discussion in 'Timeline' started by Grzona, Jun 18, 2023.

  1. Grzona

    Grzona

    Joined:
    Apr 10, 2018
    Posts:
    2
    I'm making Oculus Quest 1 app in Unity. First I describe whole workflow:
    1. In unity_project_1 im making animation using Unity Timeline window.
    2. After animation is done I'm building asset bundle with prefab containing components: Animator, PlayableDirector, Audio Source, everything that is needed to recreate animation.
    3. Bundle is sent to the server.
    4. In another project I'm downloading this bundle, extracting data and playing animation during runtime (in editor) - everything works fine.
    5. Same thing for android mobile phone, example scene works perfectly fine on the device (via build and run).
    6. Now I'm trying to do the same thing on Oculus Quest 1. Bundle is downloading correctly, but for some reason PlayableAsset is null.
    I made it work once, when I found that project in which I'm building asset bundles was made in editor ver. 2021.3.16f1, but VR project was 2021.3.17f1. After downgrading VR project to editor version 2021.3.16f1 and rebuilding apk - animation worked. After that I left project for another day. Next day, after rebuilding (for some logs only) PlayableAsset is null again.

    Now project versions are correct, everything happening in RAM (downloading data, bundles, etc), so I think permissions are not the issue (well, it worked once). I built asset bundle for Android with all dependencies... I have no clue what else I can do. Any tips?