Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Play mode not working

Discussion in 'Windows Mixed Reality' started by AnKOu, Feb 8, 2018.

  1. AnKOu

    AnKOu

    Joined:
    Aug 30, 2013
    Posts:
    45
    hello, I'm trying to test windows reality mixed. I click on Play Mode and the app starts in Unity but in my headset I stay in the home/hub of the mixed reality portal.

    Settings :
    • Unity 2017.3.0f3 personal edition, tried with 2017.2.1p3, not working either.
    • Windows Universal App platform
    • holokit sdk

    Have you any idea why it isn't working ?
     
    Last edited: Feb 8, 2018
  2. AnKOu

    AnKOu

    Joined:
    Aug 30, 2013
    Posts:
    45
    Works in 2017.2.1p3 in fact.
    Wasn't working at first. I launched a scene from HoloToolKit example and it worked. then I tried with my scene and it worked.
    My collegue is in 2017.3.0f3 (like me) and it works (not like me)
     
  3. JasonCostanza

    JasonCostanza

    Unity Technologies

    Joined:
    May 23, 2017
    Posts:
    341
    I had a similar problem that took me weeks to figure out what was wrong, turned out I was running Unity as an administrator. If you do that it blocks the HMD.

    High five on the Jackie Chan, had a good laugh on that one

    Let me know if that is your issue. If not, tell me what windows version you're running. To find out hit your Windows key, and type "winver", then press enter. This will give you full release information on your Windows version.
     
  4. AnKOu

    AnKOu

    Joined:
    Aug 30, 2013
    Posts:
    45
    Hello, I was running Unity in administrator indeed.

    I unchecked the option and now it works, thanks !
     
  5. TranSystems

    TranSystems

    Joined:
    Jan 10, 2018
    Posts:
    7
    Hi. Unfortunately that did not seem to work for me. I shut down the admin rights on my machine, and the Mixed Reality Portal Cliff House scene is still all I see when trying to go into Play Mode from the Unity editor. I am using Unity 2017.3.0f3 with Windows 10, Version 1709 Build 16299.248

    Any thoughts?
     
  6. JasonCostanza

    JasonCostanza

    Unity Technologies

    Joined:
    May 23, 2017
    Posts:
    341
    Admin rights on the machine is different than running the Unity executable as an administrator. Right click the Unity.exe and go to Compatibility and disable "Run as administrator".
     
  7. edwon

    edwon

    Joined:
    Apr 24, 2011
    Posts:
    180
    I'm having the same issue, can't see my game when I hit play in the Unity editor, just stays in windows home/mixed reality portal. I'm using Unity 2018.1.0f2, Windows version 1709, a Razer Blade laptop from 2017 with an Nvidia 1060 gpu (this setup works fine for Oculus and Vive).

    I tried disabling "run as administrator" on the unity.exe but that didn't fix it.
     
  8. edwon

    edwon

    Joined:
    Apr 24, 2011
    Posts:
    180
  9. Hanne_Huygelier

    Hanne_Huygelier

    Joined:
    Jan 4, 2017
    Posts:
    9
    Hi! I just updated my Unity version and now I am experiencing a similar issue with Oculus Rift and in Unity 2018.3.1.f1. When I start Play mode the game plays in Unity3D, but I am stuck in the home menu of Oculus in the headset. I tried running Unity as admin and not as admin, but this didn't have an effect on the issue. I also checked, but VR is still enabled and I'm still allowed to run non-verified applications by Oculus. Anyone with an idea what I could do to fix this?
     
    kittphi likes this.
  10. docas

    docas

    Joined:
    Aug 28, 2013
    Posts:
    28
    Same issue as Hanne.. my app does not launch as a VR app
     
  11. BigBoiiiEswin

    BigBoiiiEswin

    Joined:
    Sep 26, 2018
    Posts:
    2
    Same issue, UnityEditor is not run as administrator. Game starts playing, head is tracked as well as controls but the video in the oculus is stuck in the oculus menu.
     
  12. JasonCostanza

    JasonCostanza

    Unity Technologies

    Joined:
    May 23, 2017
    Posts:
    341
    We have had a common thing where users going into 18.3 often do not have the Windows Mixed Reality package installed. This often happens when you upgrade a project into 18.3. Can you make sure you're packages are installed? To get the package, go to Window > Package Manager, then find Windows Mixed Reality.
     
    kittphi likes this.
  13. cyenketswamy

    cyenketswamy

    Joined:
    Jul 24, 2015
    Posts:
    32
    Set Holographic emulation setting to None.
     
    JasonCostanza likes this.
  14. JasonCostanza

    JasonCostanza

    Unity Technologies

    Joined:
    May 23, 2017
    Posts:
    341
    Also what @cyenketswamy said, if you have the package installed. I should have included that part. Emulation tab is under Window > XR > Holographic Emulation. Good catch cyenketswamy, thank you!