Search Unity

Play Console 64 bit problem

Discussion in 'Android' started by woordygamesinc, Aug 20, 2019.

  1. woordygamesinc

    woordygamesinc

    Joined:
    Aug 2, 2017
    Posts:
    3
    Hi all,

    Our application is available for closed-alpha tests in Google Play. We uploaded 15 versions in Play Console and everything was good. When we uploaded 16th, Play Console gives us an alert about that .aab file did not support 64 bit, It only has 32 bit native codes.

    Basically we did not change anything in unity editor.

    After this error, we built the game again and again, lots of time with different settings.


    We tried to get a build with .NET 3.5 and .NET 4

    thansk for your helps.
     

    Attached Files:

  2. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    1,956
    Deselect x86 configuration. Basically google wants you to have x64 configuration, but there's no such option in Unity. Thus you need to select only ARMv7 and ARM64.
     
  3. woordygamesinc

    woordygamesinc

    Joined:
    Aug 2, 2017
    Posts:
    3
    Thanks for your answer. I also reached that option. But, I tried to say that I could upload .aab files with the selection of ARMv7, ARM64 and also x86, and there was no problem during yesterday. Is that a new compulsory requirement that is expected from developers? Because some devices may not run the application due to this option.

    Someone says that is a bug of Play Console. After researched that, I found some subjects and tickets those are created yesterday, on some forums.

    Is there anyone who has a conclusive information?

    Thanks for your help :)
     
  4. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    1,956
    I think this is how Google intented to be from the very start - https://android-developers.googleblog.com/2019/01/get-your-apps-ready-for-64-bit.html

    It makes sense now, that it doesn't accept apps if there's no 64 bit counterpart.

    For ARMv7 it's ARM64
    For x86 it's x64.
     
  5. woordygamesinc

    woordygamesinc

    Joined:
    Aug 2, 2017
    Posts:
    3
    Thanks for your answer. Unchecking x86 solved the problem. But I should say that, Google can make sometime silly things :)

    The thread can be locked :)
     
  6. wiz-japan

    wiz-japan

    Joined:
    May 29, 2014
    Posts:
    12
    Hello,
    We are using Unity 2017.4.29f1 to meet the 64-bit requirements of Google Play.
    I referred to other people's articles and selected only ARMv7 and ARM64 and applied to Google, but the application still failed.
    Unity 2017.4.29f1 should be able to meet the 64-bit requirements, right?
    We're wondering why the application doesn't pass when we remove x86.
     

    Attached Files:

  7. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    1,956
    Extract the app bundle and see if there's indeed arm8 library and there's no x86 library
     
    wiz-japan likes this.
  8. wiz-japan

    wiz-japan

    Joined:
    May 29, 2014
    Posts:
    12
    Thank you for answering.
    I want you to see apklib.png.
    Prove that there is no x86.
     

    Attached Files:

  9. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    1,956
    Can't see what's below the image. Try maybe asking google support
     
    wiz-japan likes this.
  10. wiz-japan

    wiz-japan

    Joined:
    May 29, 2014
    Posts:
    12
    I'm sorry for omitting it.

    I have already visited support, but I was told to wait until the survey results come out, and nothing can be solved.
    I'm really in trouble and want to help ...
    The contents of the unpacked apk file are here.
     

    Attached Files:

    • apk.png
      apk.png
      File size:
      634.9 KB
      Views:
      56
    Last edited: Aug 21, 2019
  11. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    1,956
    Well the only thing I can suggest is to customize final build.gradle and add

    1. packagingOptions {
    2. doNotStrip "*/armeabi-v7a/*.so"
    3. doNotStrip '*/arm64-v8a/*.so'
    4. exclude ('/lib/armeabi/*' + '*')
    5. exclude ('/lib/mips/*' + '*')
    6. exclude ('/lib/mips64/*' + '*')
    7. exclude ('/lib/x86_64/*' + '*')
    8. exclude ('/lib/x86/*' + '*')
    9. }
    like mentioned here https://forum.unity.com/threads/suc...-play-64-bit-requirement.729035/#post-4879559
     
  12. wiz-japan

    wiz-japan

    Joined:
    May 29, 2014
    Posts:
    12
    I am using "Internal Build", so unfortunately, the idea seems not to be usable.
    If I didn't solve the problem by unchecking x86 like me, will there still be no effective solution?
     
  13. Tomas1856

    Tomas1856

    Unity Technologies

    Joined:
    Sep 21, 2012
    Posts:
    1,956
    Sadly I don't know the answer. Why can't you switch to gradle?
     
  14. wiz-japan

    wiz-japan

    Joined:
    May 29, 2014
    Posts:
    12
    We need to be ready to build with gradle and it will take a lot of time.
    Is it bad for internal?
     
  15. wiz-japan

    wiz-japan

    Joined:
    May 29, 2014
    Posts:
    12
  16. Seb921

    Seb921

    Joined:
    Aug 30, 2018
    Posts:
    18
    I build with internal and not with grandle and I also unchecked x86 but I still get the warning in google play console. I don't know what to do. Please Help.
     
  17. lvinagre

    lvinagre

    Joined:
    Mar 1, 2018
    Posts:
    1
    Thanks guys ! Have been looking around for this for some time now.

    I am using Unity 2019.1.7 and unchecking the x86 architecture worked like a charm. If it helps anyone, I have attached the config that worked for me.

    Cheers !
     

    Attached Files: