Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Physics shapes wireframe not visible in editor

Discussion in 'Project Tiny' started by smonbrogg, Apr 16, 2021.

  1. smonbrogg

    smonbrogg

    Joined:
    Dec 11, 2012
    Posts:
    12
    I cant see any debug wireframes of physics shapes in the editor in my project.

    The project was created by copying the basic Tiny3D 'hello world' sample, then at some point adding physics. Physics generally seems to work nicely, but I can't see the green debug wireframes of my shapes. I'm blind folded when creating collision shapes.

    Neither the Gizmos Toggle, nor the PhysicsShapeAuthoring gizmo checkbox makes any difference. I also added every assembly refference from the TinyPhysics example to my project.

    Any help in how to resolve this would be greatly appreciated! Thans.
     
  2. AbdulAlgharbi

    AbdulAlgharbi

    Unity Technologies

    Joined:
    Jul 27, 2018
    Posts:
    319
    make sure that the collider gizmos are checked

    upload_2021-4-16_11-35-52.png

    Also, do you have two inspectors locked?
    I noticed that gizmos may not render if you have multiple inspectors selecting different objects
     
  3. smonbrogg

    smonbrogg

    Joined:
    Dec 11, 2012
    Posts:
    12
    That was it! I had an extra inspector locked to the build configuration, for fast build & run. I closed that inspector, and now the debug wires are rendering. Thanks a lot! :)
     
    BigRookGames likes this.
  4. BigRookGames

    BigRookGames

    Joined:
    Nov 24, 2014
    Posts:
    325
    I also had this problem, and for anyone else that might have this issue, it didn't fix the gizmo when I removed the second inspector, but it did after closing all inspectors and opening a new one.