Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

pet peeves I wish could be changed

Discussion in 'Wish List' started by shaderbytes, Apr 2, 2013.

  1. shaderbytes


    Nov 11, 2010
    2 things I would like to see changed

    currently in Unity :

    anyKey - Is any key or mouse button currently held down? (Read Only)

    This should rather be named "anyInput" - and then there should still be the method "anyKey" that does what it name implies and only be fired when the keyboard is used.

    GameObject.GetComponentsInChildren - Returns all components of Type type in the GameObject or any of its children.

    Same logic as above , name of method and functionality are not inline. I would expect to use "GetComponent" to return the component on "this" Object and then GetComponentsInChildren should be used for what its name implies .. only children

    Just saying .. no hard feelings