Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Particle system not rendering from far distance

Discussion in 'General Graphics' started by JamesWolfgang, Jan 28, 2020.

  1. JamesWolfgang

    JamesWolfgang

    Joined:
    Jan 23, 2019
    Posts:
    1
    Hello!

    I am working on Unity 2019.2.
    I tried to use FlamesParticlesEffect prefab from Unity's Particles effects package and it is not rendering from afar.
    There is a distance when the PS just disappear.
    Any solution ? Thanks.

    Regards.
     
    SwixDevs likes this.
  2. EpicMcDude

    EpicMcDude

    Joined:
    Apr 15, 2013
    Posts:
    117
    Bump, I'm having this happen as well. Is there any way to change the render distance without resorting to code?
     
  3. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    2,270
    Try adjusting the Camera near/far clipping values
     
  4. EpicMcDude

    EpicMcDude

    Joined:
    Apr 15, 2013
    Posts:
    117
    My clipping planes on the main camera for near and far are 0.01 and 150 respectively, unfortunately this seems to happen when the camera is around 10-15 meters away :(

    Thank you for your reply though.
     
  5. rekindledphoenix

    rekindledphoenix

    Joined:
    Dec 6, 2017
    Posts:
    3
    Bump. Camera clipping planes .01 and 1000.

    URP/Particles/Unlit particles disappearing about 15-20 units away with Alpha Clipping on. Suggestions?

    *Edit* Changing the `Aniso Level` on the sprite from 1 to 10 helped a bit, they no longer disappear 10 feet away.

    *Edit 2* Also, particle > Renderer changing `Min Particle Size` to .02 appeared to increase visible distance from 10 meters to almost 150, which is good enough
     
    Last edited: Feb 4, 2021
    DeadCastles likes this.
  6. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    2,270
    Sounds like the texture mipmaps blur in a way that makes them clip out when lower mips are used.

    So perhaps also try using a different mip filter in the texture import settings.
     
  7. bgolus

    bgolus

    Joined:
    Dec 7, 2012
    Posts:
    12,306
  8. cheneltu

    cheneltu

    Joined:
    Jul 12, 2019
    Posts:
    1
    simply uncheck "Generate Mip Maps"