Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Panoramic Skybox Shader having a seam/line

Discussion in 'AR/VR (XR) Discussion' started by Hunubul, Feb 14, 2019.

  1. Hunubul

    Hunubul

    Joined:
    Dec 17, 2018
    Posts:
    65
    Hey!
    So there is this issue, I created the skybox material to put panoramic 360 videos/pictures to the skybox.

    The problem is, that there is a line where the edge is supposed to be, behind the camera.

    Does anyone know how to make it disappear? Here is the problem, there is no picture/video selected, so it seems the material itself has this problem.

    I started using the built in Panoramic Shader, but the issue is the exact same.

    Is there a Unity settings I can set to make it disappear? Or is there a code fix for it? Anything?
     

    Attached Files:

  2. BrainWilder

    BrainWilder

    Joined:
    Jul 24, 2018
    Posts:
    1
  3. PanayotCankov

    PanayotCankov

    Joined:
    May 28, 2018
    Posts:
    16
    Long story short - uncheck "generate mipmaps".
     
    Threeyes, Luna87, SercanAlyuz and 8 others like this.
  4. m_nejatish

    m_nejatish

    Joined:
    Mar 16, 2020
    Posts:
    2
    Thanks. This works! Just select the texture, look under the Advanced and uncheck "generate mipmaps".
     
  5. menguzat

    menguzat

    Joined:
    Aug 20, 2017
    Posts:
    15
    my skybox texture is a 360 degree hdri image and the shader type is selected "skybox/panoramic".

    there is no option not to generate mipmaps as far as I can see. what would you suggest?
     
  6. samf1111

    samf1111

    Joined:
    Sep 18, 2019
    Posts:
    16
    this is an option on the image your using under the "Advanced" dropdown.
     
  7. dumbat

    dumbat

    Joined:
    Apr 24, 2014
    Posts:
    11
    I don't see an Advanced dropdown on my editor, either on the material's Inspector, or on the Select Texture window, and there's no right-click menu I can find with it. No sign of a Generate MipMaps checkbox either.
     

    Attached Files:

  8. arfish

    arfish

    Joined:
    Jan 28, 2017
    Posts:
    735
    That's probably because the setting is for the Texture, not the shader.
     
    dumbat likes this.
  9. NodeProject

    NodeProject

    Joined:
    Jul 12, 2017
    Posts:
    1
    3 years late but I'm here just to thank you guys for this!
     
  10. jons190

    jons190

    Joined:
    Sep 13, 2016
    Posts:
    257
    And the long reach.............. I just needed this answer. Thanx all!
     
  11. IllidanS4

    IllidanS4

    Joined:
    Jul 23, 2013
    Posts:
    2
    The reason this happens is that the panoramic shader calls tex2D to retrieve the color from the texture, but that function automatically calculates the mipmap level based on the surrounding pixels and it breaks at the seam, since the x coordinate jumps from 1 back to 0 there. The shader could be fixed if tex2Dlod was called instead.
     
unityunity