Search Unity

  1. We are migrating the Unity Forums to Unity Discussions by the end of July. Read our announcement for more information and let us know if you have any questions.
    Dismiss Notice
  2. Dismiss Notice

Resolved Package Manager in 0a10 never finishes checking for updates

Discussion in 'Unity 6 Beta' started by adamgolden, Oct 18, 2023.

  1. adamgolden

    adamgolden

    Joined:
    Jun 17, 2019
    Posts:
    1,558
    In 2023.3.0a10 (Windows 11), opening Package Manager, all seems well except in the bottom it says "checking for updates..." with a spinner but it never goes away. If you change filter to "Update available" the issue is more apparent, sitting at 0% forever. I have tried signing out and back in with Hub, restarting editor, nothing helps.

    checking_for_updates_forever.jpg

    Anyone else seeing this, or is it just me? Also, it's not just visual - an asset of mine on the store has a newer version, but in Package Manager it only shows the older version, no option to update, only to re-import.
     

    Attached Files:

  2. Jonathan-Westfall-8Bits

    Jonathan-Westfall-8Bits

    Joined:
    Sep 17, 2013
    Posts:
    304
    Wanted to check on this to see if I have the problem to help out.

    Just tried it on Windows 10 and set filter to update available in assets to check.
    I am not running into that issue. I tried to add more than one filter to see if I could somehow run into to it, but at the moment can't seem to replicate it on my computer.


    Might want to open up the background task window in Unity Editor and see if it says it is stuck on something.
    In Editor on the tool bar go

    Window > General > Progress to open up the tab to show currently background process doing task workloads in the editor.

    Also might want to see if anything is being logged to the console as well.
     

    Attached Files:

    adamgolden likes this.
  3. Works for me perfectly.

    Capture.PNG
     
    adamgolden likes this.
  4. Jonathan-Westfall-8Bits

    Jonathan-Westfall-8Bits

    Joined:
    Sep 17, 2013
    Posts:
    304
    Looked into this a bit right after posting my first comment a couple minutes ago.
    Could you try to first switch from My Assets to Unity Registry than back to My Assets.
    Also try this with and without the filter on at first.

    If that fixes it it might be related to a bug that was fixed in the 2022 LTS in August that might need revisiting.
    And I know exactly which Unity employee of the forum we could possibly ping for a response on it who would gladly help. He helped with previous Unity Package Manager bugs and was very good with taking care of the community with bugs related to that area of the editor.
     
    adamgolden likes this.
  5. adamgolden

    adamgolden

    Joined:
    Jun 17, 2019
    Posts:
    1,558
    Toggling back and forth to different category didn't help at first, but there was a package under "In Project" (Visual Studio Editor I think) which had an update, so I updated that, and then after when I went back to My Assets it finished getting the updates no problem, including showing the new version available to download of the asset in question (which also downloaded without issue). So.. something glitchy in there, but seems to be resolved now.

    Thanks for taking a look and for the suggestions.
     
  6. hokeypokey69

    hokeypokey69

    Joined:
    Feb 17, 2024
    Posts:
    1
    This also happened to me and I've been been trying to fix it but nothing works