Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Question One day I suddenly can't open my project, any advice?

Discussion in 'Unity Hub' started by Ferb, Mar 3, 2024.

  1. Ferb

    Ferb

    Joined:
    Jan 4, 2014
    Posts:
    25
    I don't know if this problem is with Unity Hub (though that certainly makes it worse) but I don't know which other forum would be more appropriate for this.

    Up until now I've been working on my project just fine. The only unusual things last night were that I installed a few packages (2d Sprite Editor, ProBuilder), uninstalled one (ProBuilder), and when I turned off my computer for the night, it BSODed.

    Now when I try to load up my project, it claims there are compilation errors (even though I wasn't working on code yesterday, only on scenes and assets.) I've tried choosing 'safe mode' and 'ignore' - either way it tries to keep loading indefinitely, and when I want to try anything else to get it to work, I have to restart the computer, because Unity Hub always claims the project is already open, even when no Unity Editor instances are running in Task Manager, so Unity Hub makes debugging this especially difficult, since everything I try requires a reboot! (At least this isn't in the days before SSDs when a reboot took 5-10 mins!)

    I've used github to revert the state of my project back a few commits, so whatever could have happened to my project last night, it's theoretically now in a state when it previously worked (unless changes happened that github isn't aware of, which is possible given the standard Unity git ignore file). It gives me no information about what's wrong, only the standard 'compilation issues' error message, and in the past when I've had that it hasn't prevented the Unity Editor from loading. Other projects are still opening, but not this one.

    (In terms of feedback, it would be nice if the hub had the option to try to diagnose, if not fix, a project in situations where the editor is unable to start - or at least didn't refuse to try to start the project more than once!)
     
  2. Ferb

    Ferb

    Joined:
    Jan 4, 2014
    Posts:
    25
    I only thought of that fact while typing - I think that was it, I recreated the project using only what was in source control and it now works again. I suspect ProBuilder since while trying to fix this problem I'd already gone through git deleting some files with its name on that it evidently left behind when I removed the package, it probably left more stuff behind in places that were hidden by gitignore.