Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question Oculus whining about 32-bit version undesired and target too high (33) when set to AUTO (maximum)

Discussion in 'EditorXR' started by PolyMad, Nov 6, 2023.

  1. PolyMad

    PolyMad

    Joined:
    Mar 19, 2009
    Posts:
    2,350
    I get this message from the Oculus SDK:

    "This app contains both 32-bit (armeabi-v7a) and 64-bit (arm64-v8a) libraries. This consumes extra storage and increases download times. Consider updating your build to target 64-bit only."

    upload_2023-11-6_2-46-50.png

    ARMv7 is disabled, so what can I do more?

    Before it was also whining about target to API level 33, while the maximum is 32, but I was setting it to "maximum available" as seen in a video on how to set up the proejct for VR. At least fixing it on level 32 worked.
    But I'd like to eliminate also this last warning and understand why it's showing up.
     
    Last edited: Nov 6, 2023