Search Unity

Oculus VR Splash Screen does not show

Discussion in 'AR/VR (XR) Discussion' started by ardakoyuncu, Apr 12, 2017.

  1. ardakoyuncu

    ardakoyuncu

    Joined:
    Apr 12, 2017
    Posts:
    6
    Hi everyone!

    I am trying to create a very simple splash screen where it shows a logo for a couple seconds in the VR headset before it launches to the application. (Regardless of the drawmode it just does not work. I am not trying to get rid of Made with Unity logo, just want to be able to show the logo before or with made with unity logo.)

    After I build I click the executable and it tells me the application is taking a little while to load in Rift menu. Once it loads it immediately goes to the application instead of showing me the splash screen. I disabled the resolution and quality dialog that pops right after you launch the executable. If that is enabled I see the splash screen on the tiny window on top of it but still not in VR headset. I can also view the splash screen if I hit preview in the playersettings. I am running version 5.6.0f3 and its not pro but as far as I know it should still show the splash screen regardless.

    Any help is appreciated.
    Thanks!
     
  2. karl_jones

    karl_jones

    Unity Technologies

    Joined:
    May 5, 2015
    Posts:
    4,458
    The new splash screen does not run in VR. The VR team felt that it was not suitable as it's not 3D, so when VR mode is detected it is not shown. On some VR devices a VR version of the splash will be shown but this is not connected to the splash screen settings, so won't use any logos or parameters supplied to it. Adding VR support to the new splash screen is planned for the future.
    You should be able to customise the VR version of the splash by applying a logo here:
    upload_2017-4-12_20-25-0.png
     
  3. ardakoyuncu

    ardakoyuncu

    Joined:
    Apr 12, 2017
    Posts:
    6
    I tried doing this, now I get the logo on the monitor but still the same thing in the headset. It still says please wait and then says, this scene is taking a while to load etc. And then immediately switches to the app, no splash screen in goggles. Any thoughts?
     
  4. Dois

    Dois

    Joined:
    Feb 15, 2015
    Posts:
    7
    HOWWWWWWWWWWWWWWWWWWWW?????!!!!!!!!!!!!!!!!
     
  5. dr3d

    dr3d

    Joined:
    Jan 23, 2008
    Posts:
    4
    yeah no this still not worky
     
  6. Deleted User

    Deleted User

    Guest

    @karl_jones is this supported by now? If so, which Unity Version from?
     
    BrainwareLLC likes this.
  7. Desoxi

    Desoxi

    Joined:
    Apr 12, 2015
    Posts:
    151
    Interested in this as well, 2019.3.10f1 and its still not working correctly :/
     
    BrainwareLLC likes this.
  8. BrainwareLLC

    BrainwareLLC

    Joined:
    May 4, 2020
    Posts:
    3
    This happens for me on Oculus Go after I start a new project and add an XR Rig, in 2019.3.13f1. The abd logcat show hundreds of error messages "Screen position out of view frustum (screen pos 0.000000, 0.000000, 1000.000000) (Camera rect 0 0 1024 1024) (Filename: Line: 3452).
     
  9. Deleted User

    Deleted User

    Guest

    @karl_jones I have a weird problem with the VR Splash Screen. Since we upgraded from 2018.4 to 2019.3 I recognized that starting up our app on the Oculus Quest does not show the splash screen at all, it launches with blackness.
    I then tried the used image in an empty project and it showed up fine.
    I then went in and instead of building with the BuildPlayer API, built our project the regular way. The image appeared, although it shows some small jaggyness, probably related to loading.
    I then went back in and tried building via BuildPipeline again and then I only saw the image for a split second.
    I don't know what's going on. Is it possible that the loading process of the engine has changed in that the CPU is so busy it does not manage to show it until the game launches and the SplashScreen time is over?

    We use the XR Management plugin, Universal Render Pipeline, GLES3 only.... anything else relevant?
     
  10. karl_jones

    karl_jones

    Unity Technologies

    Joined:
    May 5, 2015
    Posts:
    4,458
    Sorry I don't know what this could be. The splash screen was handled differently for vr when I last checked. Could you please file a bug report?
     
  11. firestorm185

    firestorm185

    Joined:
    Sep 23, 2014
    Posts:
    18
    The easiest way to replicate what Unity does in their 2D splash screen is to create a simple VR rig in a 3D scene, make planes with all your logos on them as materials, and animate them fading in and out. That's what I'm doing for my current project, and it's working great.
     
    makavelith likes this.
  12. firestorm185

    firestorm185

    Joined:
    Sep 23, 2014
    Posts:
    18
    I then have a script that has a simple timer on it, and after all 3 animations play with my logos (about 15 seconds of animation) the timer runs out and calls a method (a private void inside the script) that loads the next level.
     
  13. evan_spiegel

    evan_spiegel

    Joined:
    Jul 17, 2019
    Posts:
    25
    Hey there, did you ever find a solution to this? I'm having the same problem on Oculus Quest. When I build, it takes about seven seconds for the app to load the first scene, so I'm trying to put in a VR splash screen using the Player settings but the image only shows up for a split second right before the first scene loads. I'm using Unity version 2019.3.15.
     
  14. karl_jones

    karl_jones

    Unity Technologies

    Joined:
    May 5, 2015
    Posts:
    4,458
    It's worth filing a bug report for this. The splash screen is implemented differently for XR/VR.
     
  15. evan_spiegel

    evan_spiegel

    Joined:
    Jul 17, 2019
    Posts:
    25
    Maybe I'll do that, thanks!
     
    karl_jones likes this.
  16. evan_spiegel

    evan_spiegel

    Joined:
    Jul 17, 2019
    Posts:
    25
    Hi there, I submitted a bug report for this a while ago but haven't gotten any response yet. I'm working with Unity version 2019.4.14 and Oculus Quest. I used to be able to get a splash image but now it's just the dot dot dot. When you say the splash screen is implemented differently for XR/VR, can you give any more details on that? Thanks!
     
  17. karl_jones

    karl_jones

    Unity Technologies

    Joined:
    May 5, 2015
    Posts:
    4,458
    I'm afraid I don't know the specifics. Do you have a bug number?
     
  18. evan_spiegel

    evan_spiegel

    Joined:
    Jul 17, 2019
    Posts:
    25
    Yes I do! The case number is 1288228.
     
unityunity