Search Unity

  1. Looking for a job or to hire someone for a project? Check out the re-opened job forums.
    Dismiss Notice
  2. Unity wants to learn about your experiences working on a Unity project today. We'd like to hear from you via this survey.
    Dismiss Notice
  3. Unity 2020 LTS & Unity 2021.1 have been released.
    Dismiss Notice
  4. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  5. Read here for Unity's latest plans on OpenXR.
    Dismiss Notice

Help Wanted Oculus SDK issues with Microphone

Discussion in 'VR' started by visionnaireMedia, Feb 26, 2021.

  1. visionnaireMedia

    visionnaireMedia

    Joined:
    Jul 25, 2016
    Posts:
    17
    Hello everyone,

    I'm trying to make an app that allows voice chat through WebRTC, the communication works fine and all, but the missing step is having the Oculus Microphone send audio to the other side.

    I've been trying to implement the microphone part but couldn't make it work because:
    - when the app starts the microphone device can be found through Microphone.devices
    - when I activate the voice chat the microphone seems to disappear

    since no mic can be found, no audio can be recorded.

    I've been trying to implement it by myself, tried using the OVRMicInput script (which up to now seems to be the best solution) but still no luck.

    I'm currently using SoraUnitySDK to handle the WebRTC communication, the same exact code is properly working on Android Phones and even iOS (with a few changes).

    Has anyone tried something like this any made it work?

    UPDATE:
    I checked the microphone devices throughout the app and I get 3 devices, not just one. When Sora activates, no more microphones, when I deactivate sora, again 3 microphones.
     
    Last edited: Feb 26, 2021
unityunity