Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question Oculus Rift not showing Unity scene in goggles

Discussion in 'VR' started by watsonbuffaloseminary, Feb 15, 2023.

  1. watsonbuffaloseminary

    watsonbuffaloseminary

    Joined:
    Apr 17, 2020
    Posts:
    8
    Hi everyone, I'm a teacher planning to use Unity's "VR Development" learning pathway for my class. I'm following along the first few steps to set up the project, and have done everything right, however, my headset is not showing the scene once I enter playmode.

    I'm trying to use an Oculus Rift with the OpenXR, and the project says that all Meta products will work seamless but I am still running into this issue. When I use the built-in mouse-controlled rig, the project is fine, so I know that is not the problem. (I also disable it when I am trying to get the headset to work, so that is not it either)

    However, when I ensure OpenXR is clicked in the project settings and my headset is up and running, I press play and the scene does not play in my goggles.
    Is the Oculus Rift too out of date for this project or to use with Unity? I am following the exact directions and have no idea why my headset is not playing the scene. Please advise... thank you so much.
     
  2. nilagard

    nilagard

    Joined:
    Jan 13, 2017
    Posts:
    77
    Are you entirely sure that you are doing everything correct and by the book? Maybe you have forgotten to activate something? Could you post screencaps of you setting this up from start to finish and I might be able to help to identify the problem.
     
  3. watsonbuffaloseminary

    watsonbuffaloseminary

    Joined:
    Apr 17, 2020
    Posts:
    8
    Hello! Yes, I've followed the VR Development learning pathway to the tee, twice through so those would be my path. I feel as though my problem might be in using the Oculus Rift? Is there somewhere I should press so it goes to Unity? I can click to see my Desktop in the goggles but it doesn't automatically jump into the scene like it used to. Thank you so much..
     
  4. watsonbuffaloseminary

    watsonbuffaloseminary

    Joined:
    Apr 17, 2020
    Posts:
    8
    This is the pathway with screenshots.. https://learn.unity.com/pathway/vr-development

    I've even tried to just run normal Oculus without the pathway steps (rather than OpenXR) and using the Oculus VR integration, I was getting even more bugs..
     
  5. watsonbuffaloseminary

    watsonbuffaloseminary

    Joined:
    Apr 17, 2020
    Posts:
    8
    I also know there used to be a "VR Support" box to tick in the settings but that is no longer there. Thank you anyone who is able to help...
     
  6. nilagard

    nilagard

    Joined:
    Jan 13, 2017
    Posts:
    77
    How old is that course you are taking? If there has been some changes in the XR Plugin then you might have some wrong settings. Again, can you please post screenshots of all your XR setup settings?
     
  7. watsonbuffaloseminary

    watsonbuffaloseminary

    Joined:
    Apr 17, 2020
    Posts:
    8
    Hello, there is no date on the pathway but it uses Unity 2021 and I am using the same version as them -https://learn.unity.com/pathway/vr-development

    upload_2023-2-22_8-11-48.png
     
  8. nilagard

    nilagard

    Joined:
    Jan 13, 2017
    Posts:
    77
    Have you used the correct "PREFAB" when setting up your scene? Post screencaps please. - Editing since I missed DevDunk's reply. Yes, also change that and make Oculus the default runtime for XR. You can change that via the Oculus app on your computer in the settings page
     
    Last edited: Feb 24, 2023
  9. DevDunk

    DevDunk

    Joined:
    Feb 13, 2020
    Posts:
    4,877
    It says none selected as openxr runtime. Is oculus runtime set as default?
    Also I never used mock or debugger, so maybe disable that?
     
    nilagard likes this.
  10. watsonbuffaloseminary

    watsonbuffaloseminary

    Joined:
    Apr 17, 2020
    Posts:
    8
    Hi everyone, thank you for your advice. I've done these things and the scene still does not show up in my headset. The Oculus app does not allow me to click to "set it as active," or the default, the button does not work. I've attached screenshots of the windows you've mentioned, following those directions and like I said, no change. I've also attached a screenshot of the bottom right of my Unity window, the Oculus symbol is not there amongst the others, I'm not sure if that's good or bad. Again, thank you so much and I appreciate any advice!
     

    Attached Files:

  11. watsonbuffaloseminary

    watsonbuffaloseminary

    Joined:
    Apr 17, 2020
    Posts:
    8
    Also, the learning pathways says specifically to choose "OpenXR" as the plug-in provider. Thank you again..
     
  12. DevDunk

    DevDunk

    Joined:
    Feb 13, 2020
    Posts:
    4,877
    Press the big Set oculus as active on the latest screenshot
     
  13. watsonbuffaloseminary

    watsonbuffaloseminary

    Joined:
    Apr 17, 2020
    Posts:
    8
    Hello! That is the button I mentioned that does not work. Thank you..
     
  14. DevDunk

    DevDunk

    Joined:
    Feb 13, 2020
    Posts:
    4,877
    Then there might be something wrong with the oculus install. Maybe contact meta support
     
    nilagard likes this.
  15. nilagard

    nilagard

    Joined:
    Jan 13, 2017
    Posts:
    77
    That button SHOULD work, as it works on my computer no problem. You should be able to choose a standard XR provider, wether it be Oculus or Steam. Maybe try reinstall software? If all fail, try contact META as DevDunk suggested.