Search Unity

Resolved Oculus Rift Hands not showing

Discussion in 'VR' started by Tovey-Ansell, Aug 1, 2021.

  1. Tovey-Ansell

    Tovey-Ansell

    Joined:
    Jul 8, 2015
    Posts:
    150
    FIXED - See below

    I'm having some trouble with my oculus integration, after updating to the most recent version, the headset is tracked correctly, but my hands aren't working (controller buttons don't work either, although I can see in the scene view my Left and RightHandAnchors do move, so the controllers are being tracked

    If I hit build and run, hands function normally, but if I just play from the editor they're not there. I have my OVRPlayerController, with a LocalAvatar as a child of the OVRCameraRig's TrackingSpace, which is how I set it up before without any issues.

    When I use the sample scenes in the Oculus package like HandsInteractionTrainScene etc, my hands don't show up there either so don't think there's any issues with my scene

    I'm seeing a lot of stuff about messing with the android manifest file, since I'm using a rift CV1 rather than a quest I don't seem to have one of those. I've also made sure to add my appID to oculus avatar and platform, and made sure my localavatar controller shader is assigned correctly, apart from that, my googles haven't turned up any other ideas, so if anyone has any thoughts it would be super appreciated.

    My Unity version is 2019.4.3f1, and I'm using the most recent Oculus Integration package

    Cheers,
    Fred

    Edit: I've tried fresh projects with varying versions of the Oculus Integration package with same results, I can look around the scene, hands are tracking, but not showing in my scene, even after following the instructions to the letter :/

    Edit #2: Managed to fix this by migrating my project to the latest version of unity
    • Backup your project (pls)
    • Go to package manager, remove any VR related package
    • If you still have folders in assets names "Oculus" or "XR", remove these
    • Close Unity and IDE, go to Library -> scriptAssemblies, remove any files with "Oculus" in the name
    • Open Unity Hub, migrate project to Unity 2020 (in my case 2020.3.15f2)
    • Fix anything that breaks in the new version, safe mode is good for this (luckily nothing broke for me)
    • Import Oculus Integration package (latest version from asset store)
    • Go to Edit -> Project Settings, if done correctly, there shouldn't be a "XR" drop down in the "Player" menu, instead there should be an "XR Plugin Management" menu at the bottom
    • Install the XR Plugin Management thing, and select the Oculus checkbox
    • Drag and drop OVRPlayerController and LocalAvatar prefabs into your scene
    • Remember to put a plane down to stand on, otherwise you fall forever and the velocity messes up the hand animations
    • You should now be good
     
    Last edited: Aug 2, 2021
    viknesh2020 likes this.