Search Unity

Oculus Rift DK1 on Linux

Discussion in 'Linux Editor' started by cheery, Aug 28, 2015.

  1. cheery

    cheery

    Joined:
    Jan 14, 2014
    Posts:
    2
    I enabled VR on my Linux machine, but it's not doing anything with my DK1 plugged in.

    If it won't work here, I need to install the thing for nearby windows machine and switch seats during development.
     
  2. masterchop

    masterchop

    Joined:
    Oct 9, 2015
    Posts:
    38
    Did you find a solution? I am waiting for DK2 and i just saw this.
    Pretty sad if no solution yet.
     
  3. Cygon4

    Cygon4

    Joined:
    Sep 17, 2012
    Posts:
    381
    I think current Unity builds are targeting the current Rift SDK (in other words, the version after they dropped/suspended Linux support). So unless Unity's Linux group decides to backport all VR to an old SDK that still offered Linux support, you're probably out of luck. Sadly.

    Valve's Vive will offer Linux support (a given, due to SteamOS), so if Unity Linux becomes an official project, so Linux VR will probably be a thing further down the road.

    All just educated guesses, of course ;)
     
  4. haagch

    haagch

    Joined:
    Nov 9, 2014
    Posts:
    34
    The built in VR support in unity only supports windows really and seems to have mac os x support as a "bonus", but in the known bugs they always say it tears and you should use windows.

    The only oculus rift unity support that ever worked on linux was the plugin that came with the 0.6.0.0 SDK: https://developer.oculus.com/downloads/pc/0.6.0.0-beta/Unity_4_Integration/
    I have not tested that one, because it's already deprecated for the built in VR support in unity.

    Instead I have tried osvr-unity: https://osvr.github.io/build-with/
    Once osvr-core and osvr-oculus-rift is set up and ovrd and osvr_server /wherever/osvr_server_config.oculusrift.sample.json are started, it "just works":
    In the editor:
    (it actually has distortion in the editor, it just didn't find the displays config when because I didn't set it up correctly)
    A finished build (the project is for unity 4 and a bit buggy when upgraded):


    That's with the dk2. Whether it also works with the dk1 - no idea.