Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct here to familiarize yourself with the rules and how to post constructively.

  2. Unity 2022.1 is now available as the latest Tech release.
    Dismiss Notice
  3. Read here for Unity's latest plans on OpenXR.
    Dismiss Notice

Oculus Local Avatar hands not visible

Discussion in 'AR/VR (XR) Discussion' started by darryl_wright, Aug 19, 2019.

  1. darryl_wright

    darryl_wright

    Joined:
    Jul 8, 2019
    Posts:
    18
    Hello,

    I have a project (Unity 2019.2.0.f1, LWRP, Oculus 1.39, Rift-S) in which I cannot get the Oculus hands to show.

    Please note that this is not where the hands are pink because this is LWRP. The hands are not showing up at all, even though they are being tracked (they interfere with the guardian boundary correctly).

    I thought this might be something to do with the LWRP so I loaded a standard "3D" scene and loaded the Oculus integration. I didn't load anything else, and opened the localavatar scene (the one with the small avatar on the table) and the hands NOR the small avatar showed up, but again they were tracking.

    I tried the same thing in 2019.1.13.f1 and got the same result. I even deleted the oculus integration from my asset download and re-downloaded it, but I still cannot see anything in the scene.

    Has anyone else run into this? Any ideas?

    Thank you for your help.
     
    AlessiaLorenzi likes this.
  2. darryl_wright

    darryl_wright

    Joined:
    Jul 8, 2019
    Posts:
    18
    Well, I found the answer in case anyone else has this frustration. It seems as though you have to enter an app ID now even for the local avatar to show up.

    The thread was here: https://forums.oculusvr.com/developer/discussion/comment/699800#Comment_699800

    And here's a summary of what to do:

    • In your browser
      • Go to https://dashboard.oculus.com
      • Find the APP id in the left side menu tree hierarchy Manage/<myorg>/<myapp>/Getting Started API (create one if you don't have)
    • Get back to Unity3D
      • Oculus > Avatars > Edit Settings (paste your App Id)
      • Oculus > Platoform > Edit Settings (Paste your App id
     
  3. Zaclo_Games

    Zaclo_Games

    Joined:
    May 14, 2017
    Posts:
    6
  4. emrekoc85

    emrekoc85

    Joined:
    Jul 23, 2019
    Posts:
    1
    You saved my day sir. Thanks a lot
     
    AlessiaLorenzi likes this.
  5. OmniTitan

    OmniTitan

    Joined:
    Jun 20, 2018
    Posts:
    2
    I am still finding this problem with 2019.2.8f1 and putting in the AppID from Oculus does not fix it
     
  6. CWatsonT2

    CWatsonT2

    Joined:
    Jan 9, 2019
    Posts:
    72
    Also experiencing this with 2019.2.0a8 with ID in both places. It seems to be due to LWRP. If I run any of the oculus demo scenes without LWRP I see the hands/controllers fine.

    Edit - I created some shader graph shaders and put them into the shader slots of the LocalAvatar component and the hands and controller show now.
     
    Last edited: Oct 8, 2019
    viknesh2020 and canek like this.
  7. canek

    canek

    Joined:
    Sep 13, 2014
    Posts:
    21
    This worked for me too (Unity 2019.2 and latest LWRP). Thank you. I just created a default shader graph PBR shader and put it in the shader slots in the Avatar component and it worked.
     
    Last edited: Nov 4, 2019
  8. NavernM

    NavernM

    Joined:
    Sep 7, 2019
    Posts:
    4
    Does this apply to quest as well? The app id option on the developer site only checks if its development for go or rift.
     
  9. VTIL_Papageorgiou

    VTIL_Papageorgiou

    Joined:
    Dec 14, 2017
    Posts:
    11
    Yes. In Unity you can set any app id (like 12345), it doesn't have to be a valid one. There just needs to be some app id set to show the hands.
     
  10. shmendrik

    shmendrik

    Joined:
    Aug 9, 2017
    Posts:
    1
    Same here, but i found a working example theme that had everything (controllers and movement) working. Once you download the Oculus Integration package from Asset Store, and import to your project, in asset browser find "ControllerModels" scene in "Assets\Oculus\VR\Scenes" and run it. My rift shows controller hands. Resave scene with your name and import your original project into it.
     
    xushuo1236 likes this.
  11. kylehardy9

    kylehardy9

    Joined:
    Mar 15, 2018
    Posts:
    1
    I never log in to post things, but thank you so much for posting this - spent all afternoon trying to figure this out. Thank you!!!!!!
     
  12. scottgamer351

    scottgamer351

    Joined:
    Dec 1, 2019
    Posts:
    1
    Oculus > Avatars > Edit Settings where do i find that?
     
    xiaying2 and zaPuffi like this.
  13. zaPuffi

    zaPuffi

    Joined:
    Nov 26, 2019
    Posts:
    1
    I searched for it for some minutes too and I think I found it. It's on the menu bar, top left, the sixth thing.
     
  14. wadamw

    wadamw

    Joined:
    Jan 18, 2014
    Posts:
    10
    Yes! Thanks much daryl_wright.
     
  15. shaqq

    shaqq

    Joined:
    Jun 19, 2015
    Posts:
    1
    I was fighting with this problem for a while. Then I noticed an error about a dll missing. After some research I realised that there was only a 64 bit version of this library supplied by Oculus. An easy fix for me was to build as a 64 bit application instead of 32.
     
  16. NavernM

    NavernM

    Joined:
    Sep 7, 2019
    Posts:
    4
    Thanks! I did just that.
     
  17. rooster

    rooster

    Joined:
    May 22, 2009
    Posts:
    17
    So - I had the same issue and I've tried everything except building the 64 bit version. I switched to a 32 bit version before I realized I had this issue because there were different issues ...

    I have one suggestion that is a work around and worked for me fine in the 32 bit build. If you toast the LocalAvatar and put the CustomHandLeft prefab as a child to the LeftHandAnchor (ditto with the right) then the hands work fine. There is probably a shortcoming to doing this but I haven't run into it yet.
     
  18. unity_xiaokeaii98

    unity_xiaokeaii98

    Joined:
    Oct 10, 2019
    Posts:
    1
    same issue. I used to use the sample scene, save as new scene and import my stuff in. But now, even sample scenes have the same problem with the invisible hands. GG
     
  19. salvolannister

    salvolannister

    Joined:
    Jan 3, 2019
    Posts:
    46
    Did anyone tried to make the hands shows up even if not using an Oculus Headset?
     
  20. asa989

    asa989

    Joined:
    Dec 18, 2015
    Posts:
    51
    Can see my hands on a windows build? i have tried in many ways but it failed all the time!!
     
  21. CherryEngine

    CherryEngine

    Joined:
    Sep 10, 2015
    Posts:
    19
    viknesh2020 likes this.
  22. cecarlsen

    cecarlsen

    Joined:
    Jun 30, 2006
    Posts:
    703
    Thanks for pointing it out @CherryEngine. Ah, that is S***ty news. I need to use hands, but I also need to use 2020.1. Argh :(
     
  23. benmncelly

    benmncelly

    Joined:
    Mar 27, 2013
    Posts:
    4
    Oooof, just found this after hours of troublshooting with 2020....
     
  24. viknesh2020

    viknesh2020

    Joined:
    Jul 19, 2016
    Posts:
    29
    If anyone is still facing this issue, follow the below steps.

    1. Go to dashboard.oculus.com >> Create new App >> API >> Copy the App ID.
    2. Go to Unity>>Oculus on top menu>>Avatars>>Edit Settings>>Paste the App ID opposite to Quest or Gear VR.
    3. Go to Oculus on top menu>> Platform>>Edit Settings>> Paste the App ID opposite to Quest or Gear VR.
    4. Got to Oculus on top menu >> Tools>>Create store-compatible AndroidManifest.xml
    5. Go to Assets folder>>Plugins>>Android>>Delete the manifest file.
    5. Go to Hierarchy>>LocalAvatar>>Visibility>>Check Start With Controllers.
    6. Go to Hierarchy>>LocalAvatar>> Capabilities>> Uncheck Enable Body.

    Please note:

    i. Current version [Oculus Integration 37.0 Feb 1, 2022] of Oculus Avatar doesn't include the Quest 2 Controllers model. You will see the Rift Controllers instead of Quest 2'. Follow this link for more information.
    ii. Avatar hands and controllers will not be visible in URP.
     
  25. nudz-klecany

    nudz-klecany

    Joined:
    Oct 6, 2015
    Posts:
    2
    This has helped tremendously! In addition to that, you can try to replace shaders in LocalAvatar prefab to make it URP compatible
     
    viknesh2020 likes this.
  26. jae026

    jae026

    Joined:
    Oct 29, 2016
    Posts:
    29

    So there is nothing you can do to show hands while using URP?
     
  27. viknesh2020

    viknesh2020

    Joined:
    Jul 19, 2016
    Posts:
    29
    There is. Rewriting a shader which supports URP will work fine.
     
unityunity