Search Unity

[Oculus] Inconsistent frame rates in editor / build

Discussion in 'Unity 5 Pre-order Beta' started by JonDadley, Dec 15, 2014.

  1. JonDadley

    JonDadley

    Joined:
    Sep 2, 2013
    Posts:
    139
    In Unity 5 (every beta I've tried so far) with the Oculus SDK, I have an issue where the first time I hit Play in the editor, I'll have a low frame rate (somewhere around 60 - 70). If I stop and then press Play again, the frame rate will jump by 20+ frames per second. It remains at this rate every time I press Play after this for the remainder of the session.

    If I close the editor and open it again, the cycle starts again. Low frame rate the first time I press play, high frame rate every time after.

    The big problem is that this behaviour seemingly carries over into builds except that I can't 'stop and re-start' the game. I load it up and get the same low frame rate I have in the editor the first time I press play. There's seemingly no way to reach the higher frame rate.

    I tried this with a normal camera and couldn't replicate the issue. It only seems to be present when using the Oculus prefab. It also seems to be consistent across multiple projects. I'm using Oculus SDK 0.4.4 but had seem the issue on earlier versions of the SDK.

    Given how high the fps requirements are for VR titles, it'd be great if this could get resolved. As it is I can't hit the basic 75fps with this bug (however in editor I've seen frame rates comfortably in the hundreds on some projects).

    Anyone else having this issue?
     
  2. thep3000

    thep3000

    Unity Technologies

    Joined:
    Aug 9, 2013
    Posts:
    316
    We're checking to see if anyone at Oculus has experienced this behavior -- in the meantime can you file a bug report so that we can track this issue? Thanks
     
  3. BrotenStudios

    BrotenStudios

    Joined:
    Feb 13, 2014
    Posts:
    155
    I can't get the DK2 to work on Unity 5 Beta, I've seen similar issues to Jon.

    I run on primarily on OSX and the support under OSX is not stable yet. The frame rate is horrendous. It may do with how OSX is handling the fact that the DK2 is 75hz with a 90* rotation. The mac can not turn off the main integrated display, and has issues having a display device outside the 60hz range.

    I am lucky to get more then 4-10 fps often. And it has stretch artifacts on the edge of the lens correction when rotating the view. I believe the lens correction and chromatic filters are preforming very sub par.

    The old DK1 on 0.3.4 of Oculus works. Only have issues on the new DK2 and DK2 integration.
     
unityunity