Search Unity

  1. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  2. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  3. Want more efficiency in your development work? Sign up to receive weekly tech and creative know-how from Unity experts.
    Dismiss Notice
  4. Participate with students all over the world and build projects to teach people. Join now!
    Dismiss Notice
  5. Build games and experiences that can load instantly and without install. Explore the Project Tiny Preview today!
    Dismiss Notice
  6. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  7. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

Oculus Go not showing up in adb :(

Discussion in 'AR/VR (XR) Discussion' started by col000r, May 8, 2018.

  1. col000r

    col000r

    Joined:
    Mar 27, 2008
    Posts:
    628
    Ok, please just tell me what I'm doing wrong.

    I enabled developer mode in the oculus app, approved it on device, I installed the android skd and the oculus go adb drivers, but when I try to build and run in unity it says "No Android devices connected". When i do "adb devices", it gives me an empty list. If I connect my developer-enabled Android phone (same usb-port, same cable) it shows up in "adb devices" just fine.

    What am I missing? :(
     
  2. greggtwep16

    greggtwep16

    Joined:
    Aug 17, 2012
    Posts:
    1,427
    That should be all that is required and was all that was required for me. You could try adding an organisation to your oculus account or installing the go drivers again from their directions but that wasn't required for me.
     
  3. ormolvig

    ormolvig

    Joined:
    Nov 5, 2016
    Posts:
    2
    Similar issues.

    1. The Go one time asked if i wanted to enable USB debugging (I really really do) but my controller crapped out then, so couldn't say yes. I have never gotten that dialogue box back, despite a clean reset of Go. Any way to force that back?

    2. I am usually work on mac, but am using a windows machine for this Go project, and cannot get adb to run. Installed the .inf file, but cannot run adb command ('adb' not recognized as an internal or external command...). Stupid question, but what "terminal" would I be running adb in? I am using "command prompt" in windows
     
  4. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    2,758
  5. greggtwep16

    greggtwep16

    Joined:
    Aug 17, 2012
    Posts:
    1,427
    Can't say I know what happens if you don't accept but have you tried switching developer mode off then back on again. Maybe that will get the popup back. I'd hope you don't need to reset the go.

    Assuming you installed adb correctly, you either need to add the directory where adb is to your path or navigate to that folder before trying to invoke the command.
     
  6. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    2,758
    It's my understanding that you need to enable Developer Mode in the Oculus app on the device.
     
  7. greggtwep16

    greggtwep16

    Joined:
    Aug 17, 2012
    Posts:
    1,427
    To get the popup for USB debugging he would have already turned on developer mode. Otherwise you get a popup for transferring files instead. Also enabling developer mode is on the companion app on your smartphone, it isn't on the device itself.
     
  8. GUNAIR

    GUNAIR

    Joined:
    Aug 8, 2013
    Posts:
    3
    Hi!
    I have the same problems. Installed everything, enabled Developer mode etc.. - nothing. Empty device list. Then I turned off and on the Go several times and tried "adb devices" every time - and suddenly.. it appeared in the device list !! I opened unity 2018.1 and in the build window, the GO appeared in the device list (Good feature of 2018.1 BTW). I was so surprised, that I just put some objects in a quick test scene and tried a build. And it worked! I used build and run - and the test scene ran on my GO! But after closing it once, I have no idea, how to start it again on the GO. I cant find the app in any list in Oculus home... And unfortunately, the Go was invisible again for the "adb devices" after some time. But it worked ONE time, before falling asleep again. Felt like in the movie "Awakenings" ;-)

    I read in other forums, that you should deinstall the go drivers and install the Samsung drivers instead. But didn't work for me...
     
  9. greggtwep16

    greggtwep16

    Joined:
    Aug 17, 2012
    Posts:
    1,427
    While I've not had any of those problems, I'm also not using the cable that came with the Go. Years ago I had a similar issue with an asus tablet and after a lot of trial and error, I learned the hard way that not all cables are the same. Since then I've always used one of my million micro usb cables that seems to be rock solid.

    Might be the issue, might not be, but it's worth a shot. Since adb is much more lightweight than Unity, I got in the habit of always checking adb devices right when I plug it in. I also usually switch it to wifi via adb tcpip 5555 when it appears that way I don't need to leave it plugged in.

    I hope you track down your issue.
     
  10. greggtwep16

    greggtwep16

    Joined:
    Aug 17, 2012
    Posts:
    1,427
  11. ormolvig

    ormolvig

    Joined:
    Nov 5, 2016
    Posts:
    2
    well seems to kinda be working. downloaded the new drivers, ran adb devices, which identified go as unauthorized. next time i put on go, pop up screen to allow usb debugging returned. so that was good.

    it still takes a few rounds of powering off and replugging usb cable, but when that works for adb, I then can build and run to go with no issues. So massive improvement. thanks all
     
    greggtwep16 likes this.
  12. NotQuiteSmith

    NotQuiteSmith

    Joined:
    Oct 27, 2013
    Posts:
    62
    OK this is ridiculous. I ONLY bought a Go so I could hook it up to Unity and write an app for it. The hurdles to simply getting the Go even RECOGNISED on a PC is RIDICULOUS.

    I should be able to plug it in, press the button and DO SOMETHING USEFUL. What the hell is going on with these people. Make it work!

    Arrrrhhhghghghghgghghg.

    Any ideas? :)
     
  13. Kyodan

    Kyodan

    Joined:
    Feb 5, 2015
    Posts:
    6
    Update ADB to version 1.0.39 (or greater). Afterwards, try "adb devices" in an elevated command line to see if it helps with your Oculus Go not appearing.
     
  14. NotQuiteSmith

    NotQuiteSmith

    Joined:
    Oct 27, 2013
    Posts:
    62
    Dude! Worked first time! THANKS!

    For anyone else: https://developer.android.com/studio/releases/platform-tools. Unzip and use the ADB in here!
     
    abid1208 and Kyodan like this.
  15. abid1208

    abid1208

    Joined:
    Sep 27, 2018
    Posts:
    1
    Worked like a charm, the first time. I was trying for like 3 days without luck with the new Oculus adb 2 drivers and such but nothing worked. Thanks mate!
     
  16. BebeGene

    BebeGene

    Joined:
    Aug 31, 2017
    Posts:
    1
    Might be a stupid question as I am so flustered beyond belief trying to get this issue resolved, but how do I install the ADB from provided link?
     
  17. cachid

    cachid

    Joined:
    Oct 10, 2018
    Posts:
    1
    What worked for me is copying the files adb.exe, AdbWinApi.dll, AdbWinUsbApi.dll, and fastboot.exe into the C:/adb folder