Search Unity

  1. All Pro and Enterprise subscribers: find helpful & inspiring creative, tech, and business know-how in the new Unity Success Hub. Sign in to stay up to date.
    Dismiss Notice
  2. Dismiss Notice

Objects doesn't Render after load from Addressables with URP

Discussion in 'Addressables' started by Ylly, Aug 18, 2020.

  1. Ylly

    Ylly

    Joined:
    May 15, 2015
    Posts:
    21
    Our team had project on 2019.4 with hybrid render 0.5.0 and dots 0.11.0 and used addressables for our prefabs something like Scriptables object marked ass addressables with fields:

    upload_2020-8-18_13-10-36.png

    They are loading during runtime and work fine.

    With 2020.1 released we upgrade our project with this version and now trying using URP 9.0.0 - prev.35.
    and still with hybrid render 0.5.0 and dots 0.11.0. Shaders was upgraded for URP. Using this option in editor
    upload_2020-8-18_13-16-6.png
    works fine. All addressables loading and rendering . But using
    upload_2020-8-18_13-16-35.png
    In editor either in devices loads our prefabs in runtime but doesn't render. All Components are loaded fine all fields end etc was checked and looks correctly, but doesn't render. Any tips ? What should we check ?
     
  2. TreyK-47

    TreyK-47

    Unity Technologies

    Joined:
    Oct 22, 2019
    Posts:
    1,354
    Last edited: Aug 21, 2020
  3. Ylly

    Ylly

    Joined:
    May 15, 2015
    Posts:
    21
    We send bug report with mini project of this case. Looks like it doesn't work on mobile platform
     
unityunity