Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct here to familiarize yourself with the rules and how to post constructively.

  2. Unity 2022.1 is now available as the latest Tech release.
    Dismiss Notice

Object references go "Missing" after build

Discussion in 'Editor & General Support' started by ISanchezV, Aug 26, 2019.

  1. ISanchezV

    ISanchezV

    Joined:
    Aug 26, 2019
    Posts:
    18
    As the title says, this has been a problem for several weeks now. It started n 2018.4 (LTS) and has persisted up to 2018.4.7f1. What happens is that, upon building, sometimes, some object references will disappear. When looking back at the Editor, I can see the field in the script says "Missing". It's usually always the same variables, but not always. It happens randomly, so I can never know if my game will work after building or not. It's a pretty serious issue, creating big problems at my workplace.

    upload_2019-8-26_11-6-12.png

    Just in case you're wondering, all the VariablesFeed script does is feed the local values of these variables to an object that wasn't destroyed since the last scene, and that's the only reference to this "Cell" variable in my whole project.

    I have found several reports of this same issue (or a very similar one), but it doesn't seem like it was fixed.
    https://forum.unity.com/threads/object-references-become-missing-after-building-the-game.561574/
    https://forum.unity.com/threads/uni...ds-randomly-change-for-entire-project.568024/

    Help, please. This is making it impossible for me to advance in my work. Thank you.
     
  2. ISanchezV

    ISanchezV

    Joined:
    Aug 26, 2019
    Posts:
    18
    No one else? No one knows? I could really use some "official" help. Or maybe I'm doing something wrong somewhere. :(

    I opened a case, too. Still nothing. Bug Case 1179382
     
unityunity