Search Unity

  1. Unity 2019.1 beta is now available.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We're looking for insight from anyone who has experience with game testing to help us better Unity. Take our survey here. If chosen to participate you'll be entered into a sweepstake to win an Amazon gift card.
    Dismiss Notice
  4. On February 28th the Feedback website will shut down and be redirected to the Unity forums. See the full post for more information.
    Dismiss Notice
  5. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  6. Unity 2018.3 is now released.
    Dismiss Notice
  7. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

NullRef error while trying to animate a character

Discussion in 'Animation' started by UltraGearGames, Jan 25, 2019.

  1. UltraGearGames

    UltraGearGames

    Joined:
    Jul 15, 2018
    Posts:
    2
    Now unity is really starting to piss me off here. I am trying to animate a character i got off the internet, but it's just BROKEN! now let me explain. I try to record movements, and half the time it doesnt capture them, instead, it just outputs NullReferenceExceptions about Failing to add a curve or something. Then also, when i try to move the character in position, it just teleports him somewhere else for the start of the animation. When i look there, he just stays there! No matter what i do, i cant get it to work. Now, i tried doing stuff like editing the rig of the character through Unity only though, i tried setting the rig to the other options too. The only one that seemed to sort of work was Legacy, but even that had the same exact issues. I dont have any idea what this madness is, but i just cant figure this one out! I tried it on the Standard Assets's Ethan and to no surprise, it worked flawlessly. https://imgur.com/a/kZcu96d

    Update: Tried using some assets from the official Asset store, and its the exact same story. Why does nothing work suddenly?! Please help :(
     
  2. marief_unity

    marief_unity

    Unity Technologies

    Joined:
    Oct 9, 2018
    Posts:
    36
    Hi @UltraGearGames !

    Please try to reproduce your issue in a clean project with a more simple subject (ex: a cube).
    From there, try with an official Asset Store asset. And then with your initial internet character.

    The idea is to pin-point which element is breaking your workflow.

    Also please provide more details :
    - OS version
    - Unity version
    - Recorder version

    Thanks