Search Unity

Help Wanted Not enough contrast... not deep enough blacks (using Standard Render Pipeline)

Discussion in 'Editor & General Support' started by daveinpublic, Dec 19, 2020.

  1. daveinpublic

    daveinpublic

    Joined:
    May 24, 2013
    Posts:
    68
    Hey,

    I have a game that I feel like the contrast is too low. I thought the blacks should be blacker, but wasn't sure if it was my eyes not seeing it correctly.... I tried turning down every light, looking through every setting in the lighting window.

    Then I upgraded my project to URP, and all of a sudden I got the darker blacks I was wanting. The problem is, I can't use URP yet, because of a few issues, so I have to go back to the standard renderer, which has the grayish blacks.

    Below you can see Standard (Left) and URP (Right):





    Is this a common issue? Am I missing something basic? All my settings are exactly the same in the lighting window (fog, environmental lighting), and am using the same number of lights.
     
    Last edited: Dec 19, 2020
  2. Mauri

    Mauri

    Joined:
    Dec 9, 2010
    Posts:
    2,465
    Both new rendering pipelines HDRP and URP handle lights (and overall rendering) differently:
    (Source)

    Have you tried lightmapping your Scene?

    .
     
  3. daveinpublic

    daveinpublic

    Joined:
    May 24, 2013
    Posts:
    68
    Thanks for the help!

    I wound up finding a different fix. In SRP, I went to the Lighting window, under Environmental Reflections, decreased Intensity Multiplier to 0. Now it looks like URP even though URP's Intensity Multiplier is still at 1.
     
unityunity