Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We have updated the language to the Editor Terms based on feedback from our employees and community. Learn more.
    Dismiss Notice

Bug Not able to run the debugger. Help!

Discussion in 'Editor & General Support' started by adreamvoyager_unity, Jan 24, 2023.

  1. adreamvoyager_unity


    Oct 16, 2018

    I am having an issue that I cannot seem to resolve. Inside visual studios 2019 and 2020 (I tried both versions) I get the error, "The operation could not be complete. Unspecified error" when I click "Attach to Unity and Play." I'm trying to locate a logical error in my code and this is preventing me from debugging my code and setting break points. Here is an image of the error if it helps.


    I have searched for solutions to the issue and tried many things. I deleted all of the sln files. I deleted the visual studio files in the temp directory in the app data folder. I deleted the hidden .vs file. I clicked the "rebuild project solution" button with all items checked in the preferences page. I updated visual studio. I switched from Visual Studio 2019 to 2020. None of them have worked so far. If anyone has any suggestions please let me know.
    Last edited: Jan 25, 2023