Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Normal map strange seam problem

Discussion in 'General Graphics' started by MateuszW, May 13, 2015.

  1. MateuszW

    MateuszW

    Joined:
    May 13, 2015
    Posts:
    1
    Hello!

    I have a problem with normal maps in Unity. When I apply one on a mesh seams are still sharp edges and seams are still visible which is not a case in Unreal.
    I've already tried flipping green and red channels of normal map but without success.
    Hope You can help me.
     
  2. theANMATOR2b

    theANMATOR2b

    Joined:
    Jul 12, 2014
    Posts:
    7,790
    So - where is the seam? And where is sharp edges? In the box I don't see it. Looks real similar to the right image.

    Maybe your lighting setup has something to do with it or the texture setup.
     
  3. StaffanEk

    StaffanEk

    Joined:
    Jul 13, 2012
    Posts:
    380
    Last edited: May 15, 2015
  4. Zicandar

    Zicandar

    Joined:
    Feb 10, 2014
    Posts:
    388
    There is a MUCH easier solution, IMPORT TANGENTS!
    Unity's autocreation of tangents is pretty crappy, yes really, it even creates ones that shouldn't be possible! (Semi mirrored ones?!)
    To do this you will need to Export tangents from your favorite 3d program, (fbx's work, .obj's do NOT!).
    Then on the models Import Settings, you can set it to import tangents. Problem's gone!
     
    theANMATOR2b likes this.
  5. phil_lira

    phil_lira

    Unity Technologies

    Joined:
    Dec 17, 2014
    Posts:
    580
    Well there's two things:

    1) Tangents. You can import from your model or let Unity calculate for you. If you are unsure about how to export in your 3d program it let Unity calculate. In the great majority of cases it works fine.

    2) On your Texture import setting make sure to set Texture type to Normal Map.
     
unityunity