Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

No Tiles?

Discussion in '2D' started by Craggerlongclaw, Oct 30, 2019.

  1. Craggerlongclaw

    Craggerlongclaw

    Joined:
    Oct 30, 2019
    Posts:
    2
    I am new to Unity, and I am following a tutorial, which wants me to create a tile, but when I right-click and hover over "create," "tile" does not show up.
     
  2. eses

    eses

    Joined:
    Feb 26, 2013
    Posts:
    1,351
    @Craggerlongclaw

    I have no idea what tutorial you are watching, and what steps you took to create the tile (where do you right click?)...

    But in general you can create a new Tile asset, like any asset file, by right clicking in Project view (not scene view) then select Create/Tile from popup menu.

    Then you are prompted to browse a folder where to create the tile, do that and also give the Tile a name now or use default name and rename the Tile later.

    Edit: Then there is a shortcut - you can also take an existing Sprite asset, and drag that to Tile Palette (Editor window) and this too will prompt you to select a folder where Unity will generate a new Tile asset for you.
     
  3. APSchmidt

    APSchmidt

    Joined:
    Aug 8, 2016
    Posts:
    2,712
    Make sure the 2D packages are installed in Window/Package Manager.
     
    Craggerlongclaw likes this.
  4. Craggerlongclaw

    Craggerlongclaw

    Joined:
    Oct 30, 2019
    Posts:
    2
    @eses It will not pop up anywhere in the create menu.
     
  5. eses

    eses

    Joined:
    Feb 26, 2013
    Posts:
    1,351
    @Craggerlongclaw

    Which version of Unity are you using? Remember, we can't see your screen...

    Like @APSchmidt said, if you are using for example 2019.x you'll have to first open Package Manager, and install 2D Tilemap package.

    Then you'll get the Tile and Tilemap options in your menus like I mentioned.
     
    Craggerlongclaw likes this.
  6. Xenosthene

    Xenosthene

    Joined:
    Sunday
    Posts:
    1
    OK, thanks everyone :)

    I had the same problem and could solve it by following these steps :
    - Window > Package Manager
    - In Package Manager : on the right of the "+" sign, I clicked on the small reversed triangle and selected "In Project" (but "All Packages" will obviously work).
    - I clicked on "2D Sprite", then, in the bottom right corner of the window, clicked on "Install"
    - Did the same with the package named "2D Tilemap Editor" (bottom right corner, "Install")
    - Then, I CLOSED Unity and launched it again.

    Don't exactly know what did the deal but it did :)