Search Unity

  1. Unity 2019.1 is now released.
    Dismiss Notice

No shadows in android build

Discussion in 'Android' started by ZartApp, Jun 19, 2018.

  1. ZartApp

    ZartApp

    Joined:
    Jun 19, 2018
    Posts:
    2
    Has anyone experienced any issue with real time lighting for Android projects? I have tried the following

    Direction Light with : Hard Shadows, Very High Resolution, default everything else

    Project Settings/ Quality : Hard and soft shadows, Very High resolution, shadow distance = 50, default everything else

    All settings in Lighting as default (except changing environment source to colour)

    Cast and receive shadows is on for every object

    Phones : Xiaomi mi 6 and Samsung galaxy s4 mini

    And the damn thing still won't work, any ideas
     
  2. JuliusM

    JuliusM

    Unity Technologies

    Joined:
    Apr 17, 2013
    Posts:
    329
    You are probably editing a different quality level than the one that is used. Open quality settings and notice that in each column one of the check marks is green. This is the default quality setting for that platform. Make sure that the quality level which you are editing is set as default for Android platform (you can do that by clicking on the "arrow down" in "Default" line).
     
    ZartApp likes this.
  3. ZartApp

    ZartApp

    Joined:
    Jun 19, 2018
    Posts:
    2
    My quality settings.
     

    Attached Files:

  4. ZartApp

    ZartApp

    Joined:
    Jun 19, 2018
    Posts:
    2
    Hi, thanks for answer, but I tried different settings of the shadows, the shadows appeared, but after a while the shadows began to twitch (translated using Google Translate)
     
  5. AxPetre

    AxPetre

    Joined:
    Jun 1, 2013
    Posts:
    96
    Shadows are a problem on some mobile devices (like Samsung Galaxy S4). What I discovered is that shadows can disappear or become truncated when there are very large shadow receiver objects (like terrains).
     
    ecv80 likes this.