Search Unity

No shadows for area lights with progressive lightmapper

Discussion in '2018.1 Beta' started by nastalski, Apr 29, 2018.

  1. nastalski

    nastalski

    Joined:
    Jul 18, 2016
    Posts:
    1
    Hi, I just tried 2018.1.0f1 and I am unable to bake shadows for area lights using progressive lightmapper. I am using default settings and the shadows bake fine using Enlighten.

    Is this a bug or do I have to do something special to enable shadows, or have they not been implemented?

    I tested same scene on 2017.4 and there's no issue there.

    Thanks
    Zee
    Enlighten.PNG Progressive.PNG
     
    AntonioModer, Spoonfishlee and konsic like this.
  2. Jesper-Mortensen

    Jesper-Mortensen

    Unity Technologies

    Joined:
    Mar 15, 2013
    Posts:
    196
    That sounds like a bug. We will look into that. Thanks.
     
    AntonioModer likes this.
  3. kemalakay

    kemalakay

    Unity Technologies

    Joined:
    Jul 12, 2016
    Posts:
    224
    Hey @nastalski

    I've just tried to reproduce this problem using 2018.1.0f1 but failed to do so. I can see that the lightmap static GameObjects successfully cast shadows to the lightmap with an Area Light. There are a couple of questions I'd like to ask:

    1) Did you upgrade your project or created a new project from scratch by using a template? (i.e. 3D, 3D with Extras, etc.)
    2) If you used a template, which template you picked? (because High End and Low End templates change the render pipeline)
    3) Is Realtime GI enabled?

    If it's a project you upgraded and don't run into this issue when you create a new project from scratch (with templates), then it'd be appreciated if you can share your project files with us so that we can reproduce the problem on our end.

    Thank you for your help!
     

    Attached Files:

    AntonioModer likes this.