Search Unity

  1. Check out the Unite LA keynote for updates on the Visual Effect Editor, the FPS Sample, ECS, Unity for Film and more! Watch it now!
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Improved Prefab workflow (includes Nested Prefabs!), 2D isometric Tilemap and more! Get the 2018.3 Beta now.
    Dismiss Notice
  4. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice
  5. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice

No Root Transform Rotation or Position option available in fbx inspector

Discussion in 'Animation' started by Grhyll, Mar 11, 2015.

  1. Grhyll

    Grhyll

    Joined:
    Oct 15, 2012
    Posts:
    76
    Hi,

    This is probably related to new Unity 5 settings; I can't see the Root Transform Rotation and Position options in newly imported fbx, in "Animations" panel of inspector.

    On an "old" fbx, imported before switching to Unity 5:
    RTPCorrect.png

    On a "new" fbx, imported with Unity 5:
    RTPIncorrect.png

    The animators are 100% sure they didn't change a thing in export settings. I'm not even sure it has anything to do with Unity5, but it seems likely.
    On the "old" anim, if I change the Root Motion Node to any other value than "<None>", the Root Transform Rotation and Position options disappear, replaced by "Root motion is driven by curves", but they come back if I set it to "<None>" again.

    Any idea on what could cause those options to be missing?
     
  2. Grhyll

    Grhyll

    Joined:
    Oct 15, 2012
    Posts:
    76
    Well, in case anyone would have the same issue: it came from the model used to create the avatar set in the fbx. In the Rig panel, Root node was set to None instead of the root of the model itself. After changing it, then clicking Update in the Rig panel of the animations fbx, the desired options came back.
     
  3. chrisguy136

    chrisguy136

    Joined:
    Mar 24, 2015
    Posts:
    1
    Thanks! I was having trouble with this.
     
  4. GilesDMiddleton

    GilesDMiddleton

    Joined:
    Aug 12, 2015
    Posts:
    90
    I've just experienced this in Unity 5.5 - my options were there a second ago, and now they're not. I've got Root Node set and individual motion roots set, but these options don't want to appear.

    I'm loathed to try re-importing the model again, because I've tweaked all the animation frame loops etc. Is there another solution?

    (I'm importing using straight .blend files)
     
  5. GilesDMiddleton

    GilesDMiddleton

    Joined:
    Aug 12, 2015
    Posts:
    90
    I think I've possibly found the answer - Even though I'm sure I'd already done this, maybe a change had affected the import:

    I removed root motion from the individual animation's motion settings (set to none)
    I re-applied scale & rotation to both the armature and object in blender.
    Re-saved.
    Suddenly the options came back. although I've got another funny issue - I lost an eyeball!
    Screen Shot 2016-11-12 at 12.14.43.png
     
  6. krisventure

    krisventure

    Joined:
    Mar 24, 2016
    Posts:
    44
    I'm just having the same issue, tried the above solution, setting root node to the model but root motion transform still not showing up. It's a relatively recent character downloaded from assets store
     
  7. GilesDMiddleton

    GilesDMiddleton

    Joined:
    Aug 12, 2015
    Posts:
    90
    I think it goes like this... (someone punish me if I'm wrong!).

    These options seem to only appear if
    * You have the rig->root node set to the root node of your armature
    * The individual animation->motion->Root Motion Node set as None.

    This is so you can override the behaviour of the root bone movement with specific options, because the model doesn't have a custom root motion bone other than the root bone.


    To use a more specific/custom bone, you then choose the animation->motion->Root Motion Node, but your options vanish because it's assumed your custom bone provides the correct rotation/movement you require.

    I had thought use of a custom bone was a per-animation setting, but sadly it's not, as I've just discovered your rig either uses the root bone or all animations use a custom bone. I guess it makes sense in hindsight.

    Hope that helps.

    (edit)Why this is useful:
    This means you can have most of your animations move around and rotate based solely on the rig's root bone.
    But if you prefer 'in place animation techniques', with a floating bone that providing movement data, then you can nominate that as the source of motion instead of the rig's root bone. Typically this bone needs to be a child of the root bone, so that offsets can be calculated. I tried not making it a child bone and you get mad results.

    - I wish the Unity help told me this in the way I've described above. It's something I've only just had the 'eureka' moment for.
     
    Last edited: Nov 19, 2016
    BryanO likes this.
  8. chummypixels

    chummypixels

    Joined:
    Dec 22, 2016
    Posts:
    1
    Thanks i ran into the same problem. This saved time.
     
  9. Rahd

    Rahd

    Joined:
    May 30, 2014
    Posts:
    176