Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

No development environment?

Discussion in 'Unity Remote Config' started by NALStudio, Feb 7, 2021.

  1. NALStudio

    NALStudio

    Joined:
    Nov 2, 2018
    Posts:
    3
    I don't know if I have done something stupid, but my project doesn't have a development environment... This would be otherwise fine, but I need to test some stuff privately and I can't use any other environment than that to test it in the editor. I cannot make a new development environment since it doesn't allow me to make one.

    Something weird I found was that my Unity Editor is currently just downloading the config from the default environment set in the dashboard.
     

    Attached Files:

  2. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    I'm not clear what you are showing in the screenshot. Please show your Remote Config Editor settings from the Unity editor. Ensure you are using Remote Config and not Remote Settings.
     
  3. at_

    at_

    Joined:
    Oct 29, 2018
    Posts:
    24
    We're experiencing this too but assumed it was by (unfortunate) design.

    In 2.x versions, development is a reserved environment name and has been documented as such but it seems unreasonable that the built-in development environment cannot be accessed at all.

    If I'm reading the documentation right, downgrading to version 1.0 would provide legacy access to the development environment and this would persist even if upgrading back to 2.x versions?

    Might be worth a try but this also seems like an unnecessary hoop to jump through.
     
  4. NALStudio

    NALStudio

    Joined:
    Nov 2, 2018
    Posts:
    3
    Yes I am using Remote Config... (Version 1.4.0) I just can't make a development environment to test my application.
    upload_2021-2-8_16-9-3.png upload_2021-2-8_16-9-20.png
     
  5. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    Just use a different name? Also, I might recommend upgrading to 2.0.1
     
  6. at_

    at_

    Joined:
    Oct 29, 2018
    Posts:
    24
    If using a different name, the environment won't be linked to development mode builds in any way, correct?
     
  7. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
  8. at_

    at_

    Joined:
    Oct 29, 2018
    Posts:
    24
    We are using the newest version of Remote Config (2.0.1). What I meant to confirm is that toggling the Development Build button in build settings does not automatically toggle to any specific Remote Config environment in versions past 1.0.
    If so, I don't understand why accessing the (apparently always existing) Development environment requires downgrading to 1.0.x before upgrading back to 2.0.1 again.
     
  9. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    Don't downgrade https://docs.unity3d.com/Packages/com.unity.remote-config@2.0/manual/Environments.html
     
  10. Damast

    Damast

    Joined:
    Apr 25, 2019
    Posts:
    11
    Is there any way to access the Development environment without downgrading?
    Can I link another environment to the "Development Build" button in the Build settings?
     
  11. JeffDUnity3D

    JeffDUnity3D

    Unity Technologies

    Joined:
    May 2, 2017
    Posts:
    14,446
    What is your issue?
     
  12. tagh

    tagh

    Unity Technologies

    Joined:
    Aug 16, 2017
    Posts:
    22