Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only.

    Please, do not make any changes to your username or email addresses at id.unity.com during this transition time.

    It's still possible to reply to existing private message conversations during the migration, but any new replies you post will be missing after the main migration is complete. We'll do our best to migrate these messages in a follow-up step.

    On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live.


    Read our full announcement for more information and let us know if you have any questions.

Question NGO for VR packets jitter in local network

Discussion in 'Unity Transport' started by HRDev, Jun 22, 2023.

  1. HRDev

    HRDev

    Joined:
    Jun 4, 2018
    Posts:
    62
    Hello to everyone.
    I have an VR Escape Room with the software developend by me. I use a PC as Host and 8 Meta quest 2 for the players. The game is ful local, i use internet only to download initial validation data and to sent user collect data.

    I developed it with unity 2022.1.19, NGO, Unet transport and everything work well.

    Now i have updated unity to 2022.3.2 LTS, NGO to 1.5.1 and use Unity Transport 1.3.4 (tryed with 2.0 too) and here starts the problems:

    Evrything starts lagging, even if i am on a local network (we use netgear orbi pro wifi6 routers) but not always, only when players mooves a bit or turn around, if the players stays without mooving it is all smooth.

    The meta quest 2 is not overloaded, cpu usage around 40% e gpu usage around 70%.

    The fun fuct is that the Quest 2 i use only for dev is always smooth but all the others, with the same settings and the same software have this problem. The more fun fuct is that in the other office, with the same software, pc, router and headset all headsets works smooth...

    in my tests i see that when is smooth the headset sends X packets, but when start mooving and so start lagging it stop sending packets for a fraction of secods then arrive all the packets togheter causing this lag effect...

    I've been trying to solve this problem for a week working on it night and day but nothing to do ... I'm going crazy ... if does anyone have any suggestions saves my life. :(

    I really don't understand how on one headset everything is fine, and on the others with the same software and settings there is this problem...
     
  2. simon-lemay-unity

    simon-lemay-unity

    Unity Technologies

    Joined:
    Jul 19, 2021
    Posts:
    441
    When you upgraded to 2022.3, did you also upgrade to NGO 1.5.1 at the same time or were you already on this NGO version when you were using 2022.1? And if you still have a version of your project for 2022.1, did you try using Unity Transport on that version of the project instead of UNet? The answers to these questions might help point out which part of the update caused the issues to start appearing.

    Otherwise I would recommend looking at the Network Profiler for any suspect patterns of traffic (i.e. differences between a scenario where everything works well and one where you see issues). You could also add RNSM to your builds to monitor latency at runtime. Both are part of the multiplayer tools package.

    That things start working fine in a different office might indicate differences in the wireless conditions in the office where the issue occurs. You could perhaps use some Wi-Fi analyzer tool to look at quality of the signal in your environment. Another option would be to use the ping command line tool to send a large number of pings to your headsets from your host. The tool should report packet loss statistics. A large amount of packet loss can sometimes be observed in noisy wireless environments, and since NGO makes heavy use of reliable traffic delivery, this often leads to latency spikes because of head-of-line blocking when packets are lost.
     
  3. HRDev

    HRDev

    Joined:
    Jun 4, 2018
    Posts:
    62
    Ok i reinstalled unity 2022.1.24f1 with NGO 1.5.1, Unity transport 1.3.4 and works well with no problems, so the problem is in the unity version?
     
  4. simon-lemay-unity

    simon-lemay-unity

    Unity Technologies

    Joined:
    Jul 19, 2021
    Posts:
    441
    That's what it would seem like. It's a bit strange that the issue somehow disappeared after reinstalling the editor, but I'm not going to argue with a problem that fixed itself.

    You might still want to check if perhaps the issue was caused by an outside factor like the Wi-Fi quality. You may also want to test your game with the network simulator that ships with the multiplayer tools package (there's also a small basic simulator that ships with Unity Transport in NGO itself). If you can reproduce the same issue on a simulated "bad" network, it could point to the problem being caused by some external factor.
     
  5. HRDev

    HRDev

    Joined:
    Jun 4, 2018
    Posts:
    62

    I updated to "fix" the problem to 22.3.3, which improves the situation but doesn't fix it.
    The problem is not the network because builds made with 22.1.24 work fine on the same network.