Search Unity

  1. Unity 2020.1 has been released.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Newbie woes

Discussion in 'Getting Started' started by gavinprior, Jul 27, 2020.

  1. gavinprior

    gavinprior

    Joined:
    Jul 27, 2020
    Posts:
    6
    Hi All

    I had a really nice version of the GoKart minigame (using 2019.4.f1) working after I had gone through all of the tutorials. When it came to uploading to Unity to share, the game built and uploaded fine but a problem was that after pressing play you are stuck on the same screen with no ability to do anything (the game works fine in the editor). I read somewhere that there wasn't full support for WebGL or something in web browser(?).
    Assuming I needed to update WebGL and all older Packages I spent a good chunk of the day updating Packages to the latest version. This resulted in a good couple of hundred errors(!) and a non useable game.

    I've also tried updating to the Beta version (using 2020.01.b16) to no avail.

    Other than uninstalling and starting all over again, any ideas?
     
  2. Joe-Censored

    Joe-Censored

    Joined:
    Mar 26, 2013
    Posts:
    8,759
    2020.1 has a real release out. Don't use an earlier beta at this point.

    But if this were me, I would switch to stand alone windows or mac and produce a build. See if the issue is when you create builds in general or just with webgl builds. If you see the issue with the stand alone build, then check the Player log file to see if any unexpected errors are showing up. As far as testing the WebGL build, verify you see the same behavior on multiple browsers.
     
    gavinprior likes this.
  3. gavinprior

    gavinprior

    Joined:
    Jul 27, 2020
    Posts:
    6
    Thanks Joe. I'll give that a try.
     
  4. gavinprior

    gavinprior

    Joined:
    Jul 27, 2020
    Posts:
    6
    Ok, so latest version installed but still getting compile errors. It seems there's a conflict of sorts with ML_Agents. For Instance:

    "GUID [c3b291e1cd0c64781861652b579d0ac1] for asset 'Packages/com.unity.ml-agents/Editor/AgentEditor.cs' conflicts with:
    'Assets/Karting/ML_Agents/Editor/AgentEditor.cs' (current owner)
    We can't assign a new GUID because the asset is in an immutable folder. The asset will be ignored."

    and..

    "Assets/Karting/ML_Agents/Scripts/Academy.cs(8,7): error CS0246: The type or namespace name 'Barracuda' could not be found (are you missing a using directive or an assembly reference?)"

    Any ideas? I'll keep looking in the meantime!
     
  5. XanderN

    XanderN

    Joined:
    Jul 28, 2020
    Posts:
    1
    it just wont lode AHHHHHHHH
     
  6. DaDonik

    DaDonik

    Joined:
    Jun 17, 2013
    Posts:
    246
    That is not very constructive.
    What are your PC specs?
     
  7. Joe-Censored

    Joe-Censored

    Joined:
    Mar 26, 2013
    Posts:
    8,759
    It looks like you have ML_Agents both installed as a package and copied in its own folder at Assets/Karting/ML_Agents/. You'll need to only have one copy installed. Backup your project folder before removing one of them. I'm not that familiar with ML_Agents to suggest whether you'd need to keep the version in Karting or keep the package version, but the package would be easier to remove and potentially reinstall via the package manager.
     
  8. gavinprior

    gavinprior

    Joined:
    Jul 27, 2020
    Posts:
    6
    Not to worry. It made me laugh :)

    I'm on a Mac Laptop. I decided to not worry about it and started from scratch. It's only a learning exercise so all fine. Deleted it all and got it all back up and running - then moved on to the other platform tutorials.
     
  9. gavinprior

    gavinprior

    Joined:
    Jul 27, 2020
    Posts:
    6
    Hmm.. weird as it all worked fine and I didn't have any other versions of ML_Agents that I could see in the structure. No worries though, it's just a tutorial so deleted it and started from scratch. Got it all up and running again and moved on to the other tutorials.

    Thanks for your time and efforts to help.
     
  10. gavinprior

    gavinprior

    Joined:
    Jul 27, 2020
    Posts:
    6
    One thing to note - the problem arose because I was trying to figure out why my games weren't working when exported to WebGL and uploaded. Gawd knows what I did to bugger it up so decided not to bother with that bit..
     
unityunity