Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

New version of ARKit broke my app! Posted SDK dependencies are out of date.

Discussion in 'AR' started by solarisn, Nov 8, 2017.

  1. solarisn

    solarisn

    Joined:
    Apr 6, 2016
    Posts:
    13
    The latest version of ARKit just broke my application. I switched back to the latest stable build of Xcode in preparation for launch but face tracking doesn't seem to exist in the latest stable build of Xcode. Now I get build errors in Xcode.

    Perhaps face tracking should be its own independent plugin? At the very least, you should update your posted minimum requirements on BitBucket and the asset store to reflect the new Xcode version requirement.

    Thanks for all your work on this plugin!
     
  2. solarisn

    solarisn

    Joined:
    Apr 6, 2016
    Posts:
    13
    Wait... Is it possible for me to download a previous release of the ARKit SDK rather than having to revert in my version control history?
     
  3. jimmya

    jimmya

    Joined:
    Nov 15, 2016
    Posts:
    793
    Which version does not have face tracking? It should have been in there for ages. E.g. XCode 9.0.1 (release) has it in there.
     
  4. solarisn

    solarisn

    Joined:
    Apr 6, 2016
    Posts:
    13
    I downloaded the SDK as soon as it came out and didn't try updating until now. I've already reverted so my issue is fixed. All docs still claim it works with Xcode 9 beta 5 though.
     
  5. jimmya

    jimmya

    Joined:
    Nov 15, 2016
    Posts:
    793
    Tru dat - gotta fix some of the old requirements :p