Search Unity

  1. We've closed the job boards. If you're looking for work, or looking to hire check out Unity Connect. You can see more information here.
    Dismiss Notice
  2. Unity 2017.2 is now released.
    Dismiss Notice
  3. The Unity Gear Store is here to help you look great at your next meetup, user group or conference. With all new Unity apparel, stickers and more!
    Dismiss Notice
  4. If you're a macOS 10.13 High Sierra user take be sure to read this before updating Unity.
    Dismiss Notice
  5. Introducing the Unity Essentials Packs! Find out more.
    Dismiss Notice
  6. Want to see the most recent patch releases? Take a peek at the patch release page.
    Dismiss Notice
  7. Unity 2017.3 beta is now available for download.
    Dismiss Notice

New release (crash on startup)

Discussion in 'Linux Editor' started by cnheider, Dec 6, 2017.

  1. cnheider

    cnheider

    Joined:
    Apr 5, 2017
    Posts:
    6
    Great installer, but unfortunately the newly installed unity does not launch properly, getting segmentation faults after splash loader.

    Anybody else experiencing this?

    I am on debian buster.
     
  2. PJayB

    PJayB

    Unity Technologies

    Joined:
    Apr 24, 2017
    Posts:
    62
    What components did you install? Do you have a ~/.config/unity3d/Editor.log?
     
  3. cnheider

    cnheider

    Joined:
    Apr 5, 2017
    Posts:
    6
    The default (editor, documentation, standard assets),

    Code (Log):
    1. Desktop is 1920 x 1080 @ 60 Hz
    2. GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_fbconfig_packed_float GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_EXT_create_context_es_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event
    3. [Package Manager] Server::Start -- Port 35088 was selected
    4.  
    5. LICENSE SYSTEM [2017127 1:13:52] Next license update check is after 2017-12-07T17:41:50
    6.  
    7.  
    8. COMMAND LINE ARGUMENTS:
    9. ./Unity
    10. [1207/011352:ERROR:browser_main_loop.cc(161)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
    11. ATTENTION: default value of option force_s3tc_enable overridden by environment.
    12.  
     
    Last edited: Dec 7, 2017
  4. PJayB

    PJayB

    Unity Technologies

    Joined:
    Apr 24, 2017
    Posts:
    62
    Hmm, none of that looks fatal. That's also a very short log...
     
  5. cnheider

    cnheider

    Joined:
    Apr 5, 2017
    Posts:
    6
    I know... How can i help? :)
     
  6. cnheider

    cnheider

    Joined:
    Apr 5, 2017
    Posts:
    6
    Just deleted my .config/unity3d and tried again and got following the Editor.log.

    Code (Log):
    1. Desktop is 1920 x 1080 @ 60 Hz
    2. GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_fbconfig_packed_float GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_EXT_create_context_es_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event
    3. [Package Manager] Server::Start -- Port 55977 was selected
    4. npm ERR! invalid: unity-editor-home@0.8.30 /home/heider/.local/share/unity3d/Packages/node_modules/unity-editor-home
    5. ListPackages failed, output: {
    6.   "name": "unity-editor",
    7.   "version": "5.7.0",
    8.   "problems": [
    9.     "invalid: unity-editor-home@0.8.30 /home/heider/.local/share/unity3d/Packages/node_modules/unity-editor-home"
    10.   ],
    11.   "dependencies": {
    12.     "unity-editor-home": {
    13.       "version": "0.8.30",
    14.       "from": "unity-editor-home.0.8.30.tgz",
    15.       "resolved": "file:unity-editor-home.0.8.30.tgz",
    16.       "invalid": true,
    17.       "problems": [
    18.         "invalid: unity-editor-home@0.8.30 /home/heider/.local/share/unity3d/Packages/node_modules/unity-editor-home"
    19.       ]
    20.     },
    21.     "unityeditor-cloud-hub": {
    22.       "version": "0.0.15",
    23.       "from": "unityeditor-cloud-hub-0.0.15.tgz",
    24.       "resolved": "file:unityeditor-cloud-hub-0.0.15.tgz"
    25.     },
    26.     "unityeditor-collab-history": {
    27.       "version": "0.6.14",
    28.       "from": "unityeditor-collab-history.0.6.14.tgz",
    29.       "resolved": "file:unityeditor-collab-history.0.6.14.tgz"
    30.     },
    31.     "unityeditor-collab-toolbar": {
    32.       "version": "0.7.15",
    33.       "from": "unityeditor-collab-toolbar.0.7.15.tgz",
    34.       "resolved": "file:unityeditor-collab-toolbar.0.7.15.tgz"
    35.     }
    36.   }
    37. }
    38.  
    39. npm WARN unity-editor@5.7.0 No repository field.
    40. npm WARN unity-editor@5.7.0 No license field.
    41.  
    42. LICENSE SYSTEM [2017127 13:32:38] Next license update check is after 2017-12-07T17:41:50
    43.  
    44.  
    45. COMMAND LINE ARGUMENTS:
    46. ./Unity
    47. [1207/133238:ERROR:browser_main_loop.cc(161)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
    48. ATTENTION: default value of option force_s3tc_enable overridden by environment.
    49.  
    Still getting the segmentation fault.
     
  7. PJayB

    PJayB

    Unity Technologies

    Joined:
    Apr 24, 2017
    Posts:
    62
    None of that looks fatal either. It looks like your logs might be truncated. Can you run from a terminal using the commandline "Unity -logfile"? That will output all log text to stdout, rather than to a file. Maybe that'll show more information.
     
  8. cnheider

    cnheider

    Joined:
    Apr 5, 2017
    Posts:
    6
    Not much of a difference.
    Code (ConsoleOutput):
    1. ./Unity -logfile                                                                          
    2. Desktop is 1920 x 1080 @ 60 Hz
    3. GLX Extensions: GLX_ARB_create_context GLX_ARB_create_context_profile GLX_ARB_create_context_robustness GLX_ARB_fbconfig_float GLX_ARB_framebuffer_sRGB GLX_ARB_get_proc_address GLX_ARB_multisample GLX_EXT_import_context GLX_EXT_visual_info GLX_EXT_visual_rating GLX_EXT_fbconfig_packed_float GLX_EXT_framebuffer_sRGB GLX_EXT_create_context_es2_profile GLX_EXT_create_context_es_profile GLX_MESA_copy_sub_buffer GLX_MESA_multithread_makecurrent GLX_MESA_query_renderer GLX_MESA_swap_control GLX_OML_swap_method GLX_OML_sync_control GLX_SGI_make_current_read GLX_SGI_swap_control GLX_SGI_video_sync GLX_SGIS_multisample GLX_SGIX_fbconfig GLX_SGIX_pbuffer GLX_SGIX_visual_select_group GLX_EXT_texture_from_pixmap GLX_INTEL_swap_event
    4. [Package Manager] Server::Start -- Port 41623 was selected
    5. npm ERR! invalid: unity-editor-home@0.8.30 /home/heider/.local/share/unity3d/Packages/node_modules/unity-editor-home
    6. ListPackages failed, output: {
    7.   "name": "unity-editor",
    8.   "version": "5.7.0",
    9.   "problems": [
    10.     "invalid: unity-editor-home@0.8.30 /home/heider/.local/share/unity3d/Packages/node_modules/unity-editor-home"
    11.   ],
    12.   "dependencies": {
    13.     "unity-editor-home": {
    14.       "version": "0.8.30",
    15.       "from": "unity-editor-home.0.8.30.tgz",
    16.       "resolved": "file:unity-editor-home.0.8.30.tgz",
    17.       "invalid": true,
    18.       "problems": [
    19.         "invalid: unity-editor-home@0.8.30 /home/heider/.local/share/unity3d/Packages/node_modules/unity-editor-home"
    20.       ]
    21.     },
    22.     "unityeditor-cloud-hub": {
    23.       "version": "0.0.15",
    24.       "from": "unityeditor-cloud-hub-0.0.15.tgz",
    25.       "resolved": "file:unityeditor-cloud-hub-0.0.15.tgz"
    26.     },
    27.     "unityeditor-collab-history": {
    28.       "version": "0.6.14",
    29.       "from": "unityeditor-collab-history.0.6.14.tgz",
    30.       "resolved": "file:unityeditor-collab-history.0.6.14.tgz"
    31.     },
    32.     "unityeditor-collab-toolbar": {
    33.       "version": "0.7.15",
    34.       "from": "unityeditor-collab-toolbar.0.7.15.tgz",
    35.       "resolved": "file:unityeditor-collab-toolbar.0.7.15.tgz"
    36.     }
    37.   }
    38. }
    39.  
    40. npm WARN unity-editor@5.7.0 No repository field.
    41. npm WARN unity-editor@5.7.0 No license field.
    42.  
    43. LICENSE SYSTEM [2017128 3:59:20] Next license update check is after 2017-12-09T00:08:21
    44.  
    45.  
    46. COMMAND LINE ARGUMENTS:
    47. ./Unity
    48. -logfile
    49. [1208/035920:ERROR:browser_main_loop.cc(161)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
    50. ATTENTION: default value of option force_s3tc_enable overridden by environment.
    51. [1]    16077 segmentation fault  ./Unity -logfile
    52.