Search Unity

New projects max out at 74fps, loaded projects max out at thousands of fps

Discussion in 'Editor & General Support' started by unfungmz, Aug 1, 2017.

  1. unfungmz

    unfungmz

    Joined:
    Jul 29, 2017
    Posts:
    162
    This is driving me crazy. I kept creating new projects - empty ones, and just hitting 'play' and they max out at around 74 fps. However, I downloaded some example projects and they reach frame rates in the thousands. Even if I attempt to set the frame rate to something higher than 74 they still will never reach above that. Is there something in these empty scenes that is completely throttling my system?
     
  2. jilt

    jilt

    Joined:
    Nov 7, 2014
    Posts:
    49
    check your Vsync settings
     
  3. unfungmz

    unfungmz

    Joined:
    Jul 29, 2017
    Posts:
    162
    I did try turning that off as well. I'm putting this on Awake with no improved results...

    QualitySettings.vSyncCount = 0;
    Application.targetFrameRate = 1000;

    The sample files I'm using - i remove EVERYTHING and they're still faster. I would assume it has to be something in the project settings
     
  4. Dreamwriter

    Dreamwriter

    Joined:
    Jul 22, 2011
    Posts:
    472
    There are a lot of project settings which affect framerate. Things like forward rendering vs. deferred, lighting with ambient illumination, all the Quality settings, Graphics settings, etc. The default settings in new projects aren’t all set for maximum performance.
     
  5. unfungmz

    unfungmz

    Joined:
    Jul 29, 2017
    Posts:
    162
    I pretty much turned everything in graphics and quality settings all the way down and there has been no difference
     
  6. unfungmz

    unfungmz

    Joined:
    Jul 29, 2017
    Posts:
    162
    OK so I did all that THEN I changed vsync and the frame rate via script and now im getting 3,500 FPS...now I just have to figure out which setting it was that fixed it
     
  7. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,070
    probably had the wrong quality setting selected or something.