Search Unity

  1. New Unity Live Help updates. Check them out here!

    Dismiss Notice

New Objects Appear Grey Not White

Discussion in 'World Building' started by caddi, Mar 25, 2020.

  1. caddi

    caddi

    Joined:
    Mar 23, 2020
    Posts:
    8
    I just installed a fresh version of Unity 2019.3.6f1 and one thing I notice right away when following the Unity Roll A Ball game tutorial is that the objects I add are grey not white like in the tutorial. The first thing the tutorial asks you to add is a Plane and it is grey. Can someone advise why this is happening? I didn't change any settings at all.

    Thanks!
     
  2. Flavelius

    Flavelius

    Joined:
    Jul 8, 2012
    Posts:
    712
    You could open the lighting panel, disable realtime and baked global illumination and bake the lighting, this updates the environment map and often brightens up the scene to look correct.
    Also if you don't have a light in the scene this would also make everything look greyish.
    Or maybe the little lamp-icon-ed button at the top of the scene view is disabled, this makes unity ignore lights added to the scene and use some default view-only lights.
     
    Penhoat and caddi like this.
  3. linojon

    linojon

    Joined:
    Aug 25, 2014
    Posts:
    99
    Also, depending on the render pipeline, the default materials use a gray main color (#808080) instead of white.
     
    Penhoat likes this.
  4. caddi

    caddi

    Joined:
    Mar 23, 2020
    Posts:
    8
    Thanks for the quick response guys. Looks like the issue was the settings in the lighting panel. I made the changes you suggested and things look much better now.

    Thanks again!
     
unityunity