Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Need help with using python 3.7 instead of 3.8

Discussion in 'ML-Agents' started by clankill3r, Dec 21, 2020.

  1. clankill3r

    clankill3r

    Joined:
    Oct 19, 2017
    Posts:
    5
    I try to follow this:
    https://github.com/Unity-Technologi...ase_10_docs/docs/Using-Virtual-Environment.md

    When I type `python --version` I get Python 3.8.5.

    But the document clearly states:

    > This guide has been tested with Python 3.6 and 3.7. Python 3.8 is not supported at this time.

    So I installed 3.7, which is located here:

    > C:\Users\clank\AppData\Local\Programs\Python\Python37

    Now how can I follow this and the next steps onward: https://github.com/Unity-Technologi...irtual-Environment.md#installing-pip-required

    With python 3.7 instead of python 3.8.
     
  2. celion_unity

    celion_unity

    Joined:
    Jun 12, 2019
    Posts:
    289
    Sorry, that section of the documentation is out of date; python 3.8 is supported and tested. I'll update that section in the docs, and also check whether we can run with 3.9.
     
    christophergoy likes this.
  3. celion_unity

    celion_unity

    Joined:
    Jun 12, 2019
    Posts:
    289
  4. clankill3r

    clankill3r

    Joined:
    Oct 19, 2017
    Posts:
    5
    Great it works with 3.8 now as well. I remember I tried setting up the ml-agent project with students when it was still using tensorflow 1.7 and it was such a pain to get it working on all the different laptops. So far it seems it goes a bit smoother now but I keep my fingers crossed. :)