Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

NavMesh not complete ???

Discussion in 'Navigation' started by SubZeroGaming, May 31, 2015.

  1. SubZeroGaming

    SubZeroGaming

    Joined:
    Mar 4, 2013
    Posts:
    1,008
    Hey guys,

    Tried searching for this but couldn't find anything. In my game some buildings have stairs, and for all of the buildings that have stairs, a nav mesh is baked from the floor to the stairs, and I can go up and down just fine :)


    On 1 building though...this happens...How can I fix? I don't see an option to manually extend the nav mesh.



    See how it's like 3/4 on the stairs? But doesn't go to the street...why?
     
  2. SubZeroGaming

    SubZeroGaming

    Joined:
    Mar 4, 2013
    Posts:
    1,008
    Nobody has experienced this issue before?
     
  3. Samuel411

    Samuel411

    Joined:
    Dec 20, 2012
    Posts:
    622
    It looks like the max slope in the navmesh settings might be too low, try increasing it.
     
  4. SubZeroGaming

    SubZeroGaming

    Joined:
    Mar 4, 2013
    Posts:
    1,008
    Thanks for the reply. That sadly didn't fix it :(

    Hm....
     
  5. Samuel411

    Samuel411

    Joined:
    Dec 20, 2012
    Posts:
    622
    It may be that the stairs isn't registering as stairs and it thinks it's a platform so it's using the radius, that's what's giving you that missing navmesh area. Try moving the stairs lower into the ground.
     
  6. SubZeroGaming

    SubZeroGaming

    Joined:
    Mar 4, 2013
    Posts:
    1,008
    Yeah, it's a stange issue. I lowered it to the ground, and it didn't work, but then scaled it up and now I have this...

     
  7. Samuel411

    Samuel411

    Joined:
    Dec 20, 2012
    Posts:
    622
    hmm, try playing around with the variables. It might be the actual mesh itself.
     
  8. Jakob_Unity

    Jakob_Unity

    Unity Technologies

    Joined:
    Dec 25, 2011
    Posts:
    269
    A couple of things to check:
    • make sure you don't have some static 'hard to see' meshes like fog planes etc. if you do make sure they're not 'navigation static'
    • Try setting the Step Height bake settting to about 2* the step height on the stairs.