Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Navmesh baking stuck on "Exporting Tiles" with no progress.

Discussion in 'Navigation' started by ganthefan, Aug 12, 2016.

  1. ganthefan

    ganthefan

    Joined:
    Jul 16, 2015
    Posts:
    2
    After updating to Unity 5.4.0f3 I can no longer bake navmeshs. Or the navmeshs might be taking REALLY long to bake. Previously I could bake terrain in a few seconds but now when I press bake if just flashes "Exporting Tiles" at the bottom right rapidly with no progress on the bar.

    What I've Tried:
    - Insuring the object I am trying to bake is set to navigation static (set everything to static just to make sure.)
    - Set the Navigation Area in the baking window to "Walkable."
    - Tried adjusting the agent size and even looked into the Advanced tab and messed with the "Manual Voxel Size."
    - Attempted to bake a navmesh in another Scene - didn't work.
    - Clearing the GICache.
    - Waited around 2 hours for a simple 1x1x1 Unity cube - still did not bake in my project.

    I haven't tried another project yet - I will allow it to bake overnight. I really hope someone can figure out what I'm messing up. I've been working on a game for almost 2 years and it would be a serious pain to have to port it out into another project or use another pathfinding solution.
     
  2. ganthefan

    ganthefan

    Joined:
    Jul 16, 2015
    Posts:
    2
    Ok so apparently it does work. It just takes way longer than it did before.
    I'm running

    Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz

    Video Card
    NVIDIA GeForce GT 650M

    RAM
    8.0 GB

    Operating System
    Microsoft Windows 10 64-bit

    These are somewhat interesting wait times. I think they updated the navmesh with new features in 5.4 - just give it some time and it does build.
     
    alexandermhinton likes this.
  3. alexandermhinton

    alexandermhinton

    Joined:
    Jul 13, 2019
    Posts:
    1
    Thank you for following up with your own post! Good to hear, I have a huge scene that I'm trying to bake right now, and I was worried that it wasn't going to work
     
    MLipscomb, miannello and JakobeSVT like this.