Search Unity

  1. Click here to see what's on sale for the "Best of Super Sale" on the Asset Store
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Help Wanted Navigation locked until ESC pressed when selecting TMP Input Field

Discussion in 'UGUI & TextMesh Pro' started by Yemnefer, Oct 26, 2020.

  1. Yemnefer

    Yemnefer

    Joined:
    Sep 12, 2017
    Posts:
    50
    Good day everyone, I'm trying to do a UI navigation with a gamepad, the problem is, whenever I select a TMP Input Field, I'm forced to press ESC to stop typing, and only then I can continue navigating. I'm using the new input system only. A quick example.
    upload_2020-10-26_14-31-11.png
    In order for me to reach the IP input field, starting from the Private Toggle, I need to:
    Down > ESC > Down > ESC > Down
    I would like to just
    Down > Down > Down
    And then submit to start typing.

    What I have tried:
    I tried calling ReleaseSelection() and DeactivateInputField() on the OnSelect Unity Event, but nothing happens. I can structure my UI in a way it would work, I can actually think of multiple solutions, but I feel like I'm missing something, this can't be the intended behavior.
     
    Last edited: Oct 26, 2020
unityunity