Search Unity

  1. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

My findings in Ubuntu 15.10 with GeForce 770

Discussion in 'Linux Editor' started by gurayg, Jan 26, 2016.

  1. gurayg

    gurayg

    Joined:
    Nov 28, 2013
    Posts:
    232
    Hello all,

    I'm not an Ubuntu guru by any mean but I'd like to use Unity on Ubuntu if possible in the future.
    Today I've installed Ubuntu and tested the experimental Editor.
    Most of my findings are small things and don't deserve a thread on their own That's why I've made a list of them.

    What worked:

    -I was brave enough to test Unity's own "Blacksmith Hair" and "Unique shadows" assets. Both are working fine on my system.
    -Water FX Pack by Unity Technologies asset works fine (uses old particle system)
    -Also "Cinematic Effects" by Unity worked for me. (tested SSR and DOF)
    -A popular postFX package called "Scion" also worked. It seemed a bit too much brighter to me though.
    -2 screen setup worked. One screen holds the Game view, other has the regular stuff. But if I close Unity with 2 screen setup it crashes. Sometimes needs "Force Quit". I have to collect all the windows into one screen if I want a soft landing.

    Problems I've encountered on my test:

    -If you want to take a tab to a second monitor, you do that by drag-dropping from where the tab's name is.
    You can not use the empty space that is on the right of the tab's name. It acts weird in that situation.

    -I couldn't make the "fullscreen button" on the Game view to work.

    -In Windows, Alt-Left clicking in Scene window result in orbiting around the selected Game Object.
    In Ubuntu it works as Unity application window was grabbed from its title bar.

    -Shader dropdown doesn't show which shader is in use.
    If I'm remember correctly, Windows/Mac editors has a tick mark to show which shader is in use.

    -If an Editor script adds a new top menu bar item, it gets placed left to right first ( This might happen once you delete the Editor script from your project, not sure)
    So custom menu items are placed before "File", "Edit"... in some cases.

    -Cannot use keyboard arrow keys in Project window for navigation.

    - One of particle assets spammed the console with
    Invalid AABB a
    IsFinite(outDistanceForSort)
    UnityEditor.DockArea:OnGUI()
    IsFinite(outDistanceForSort)
    IsFinite(outDistanceAlongView)
    Invalid AABB result
    UnityEditorInternal.InternalEditorUtility:INTERNAL_CALL_CalculateSelectionBounds(Boolean, Boolean, Bounds&)
    UnityEditorInternal.InternalEditorUtility:CalculateSelectionBounds(Boolean, Boolean) (at /home/builduser/buildslave/unity/build/artifacts/generated/common/editor/InternalEditorUtilityBindings.gen.cs:654)
    UnityEditor.DockArea:OnGUI()

    more errors spam, if the particle prefab is selected on the Hierarchy window.
    I tracked some of the errors down to their custom particle shader. Other errors are most probably related to particle related inspectors.
    I can PM the shader file to a Unity Dev if needed.

    AssetStore tab has some small problems on its own:
    -Tooltips for assets show in random places between 2 monitors.
    -"Group by" dropdown list is kind of buggy. First it worked, then it stopped working. Then worked again! I think it is because of the weather :)
    -If the asset includes a .unitypackage file in it (publishers do that because it installs much faster into the project)
    Ubuntu Archive Manager tries to open that file and fails. I couldn't find a way around this yet.

    -While V-Sync Count is off, If Scene and Game views are opened at the same time CPU usage is very high.
    But if I replace scene view with Asset Store tab CPU usage drops down significantly.

    -Couldn't make MonoDevelop work.

    Hope any of these help.
     
  2. FuzzyQuills

    FuzzyQuills

    Joined:
    Jun 8, 2013
    Posts:
    2,869
    The "Invalid AABB" errors are actually a unity 5.3.1 bug and were fixed in 5.3.2. I seriously wish they could update the Linux build at that speed... :D

    As for the other things...
    - Window grabbing instead of the turntable rotation the scene view; that's actually caused by Ubuntu itself, not a unity bug, there's usually an option to turn off alt+drag on windows in the ubuntu settings panel somewhere.
    - Monodevelop never worked for me either... I say if you don't mind grabbing a free Microsoft product, go with VS code, it works flawlessly in most cases, given a bit of tweaking. You even get code completion, although that needs a particular version of the Mono runtime to work (sudo apt-get install mono-complete usually installs the latest mono 4.0.1 for VS Code Omnisharp to work)
    - The tab dragging behaviour is something I noticed too... :D
     
    gurayg likes this.
unityunity