Search Unity

Question Multiple Problems with Unity. Please help.

Discussion in 'Getting Started' started by Deleted User, Aug 14, 2021.

  1. Deleted User

    Deleted User


    I've just started using unity after I watched a YouTube tutorial on it and wanted to learn the basics. My experience with unity has been a nightmare. I don't know why it's so buggy but not even the installation that comes with unity hub worked correctly, I could not find the Rigidbody/Rigidbody 2D component and in the package manager all the built-in packages had the "You do not have entitlements for this package" error. I managed to fix that by downloading the 2019.4 LTS installation but it took 7 re-installs for me to figure that out. Now after doing all that unity refuses to allow me to edit the color of a material I create, mind that before when I had the installation that come with unity hub this was possible. When I click the color picker the inspector just goes blank and the on the bottom left hand corner appears "MethodAccessException: Requires Team License". I'm almost done with Unity at this point, I've lost almost 7-10 hours trying to troubleshoot it to no avail instead of actually learning stuff. Plus I can't even get the license to work properly. I go to license management I click Activate New License and there always appears "Failed to reach license server", I also tried the manual activation but then "Failed to save the License File" appears.