Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Dismiss Notice

Bug Moved unity and project folder and now almost all scripts (even unity made scripts) throw errors

Discussion in 'Editor & General Support' started by lino1000, Jun 1, 2023.

  1. lino1000


    Mar 11, 2019
    Hi everyone! So I have been working with unity for a while and been doing my game for about half a year. Everything was fine until now but I decided to move unity and the game project files from my C to my D drive because i was starting to run out of space and now I have massive problems and cant do anything anymore.

    When opening the project it immediately tells me there are compile errors and asks me to start in safe mode. If i do that or start normally doesnt change anything and it shows me 99+ compiling errors all stating the same. "The system could not find the specified path". It is not because the class name and the file name are different. Thats all, it doesnt tell me which path it was looking for, which file it should be or anything else. I tried opening an old version of my game where i know it works and same error. If I create a new project it immediately throws errors saying XXX. Also a lot of unity made scripts dont even show up (for example I have no UI scripts at all like image or button etc.) I tried reinstalling the unity version but still the same problem.

    Im assuming some kind of pointers/setting didnt update when I moved the project and its still trying to access all the basic script files on my C drive where obviously they are not anymore and thats causing everything to explode but i dont know where/how to change it (if its even the reason of it not working)

    I also tried creating a clean new project with nothing in it and I get the same errors still and all the unity-made scripts like images, buttons etc. still dont show up at all and are unusable plus of course because there are compiling errors i cant even start the empty scene or build it.

    I also tried re-installing the unity editor with no success at all.

    Anyone got suggestions on what i can do? uninstalling unity hub itself and making a completely fresh start would be doable but i would prefer not to since i have everything set up to my likings already. So any suggestions?

    Thanks to anyone who is trying to help